2000 Buick Lesabre 2000 Buick Lesabre stalls without any no

Tiny
WFRUTCHEY
  • MEMBER
  • 2000 BUICK LESABRE
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 103,000 MILES
Hi,
I have a 2000 Lesabre that stalls while driving or idling (It just shuts off with out a sign) I had the ignition control modual tested and even tried another from the local scrapyard. I cleaned the air flow sensor and replaced the fuel pump. It still stalls. My local mechanic cant figure it out. Thinking maybe a crank or cam sensor. Can anyone help. Any help would be great. Please help
Do you
have the same problem?
Yes
No
Tuesday, November 17th, 2009 AT 11:47 AM

3 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
The crank sensor could be the problem. Has the check engine light come on when this happens?
Was this
answer
helpful?
Yes
No
Monday, November 23rd, 2009 AT 9:37 AM
Tiny
WFRUTCHEY
  • MEMBER
The check engine light is not on. It does go on when it stalls. It stalled this morning twice then I unpluged the air flow sensor plug and it has not stalled yet. Of course the check engine light is on now. Have you ever had a air flow sensor short out or go bad? Thanks for your help I gotta figure this out asap. Bill
Was this
answer
helpful?
Yes
No
Monday, November 23rd, 2009 AT 9:51 AM
Tiny
RMK01289
  • MEMBER
Which air flow sensor did you unplug? My 97 lesabre is doing the same thing and I have replaced the fuel pump and coil pack and the stalling s just getting worse.
Was this
answer
helpful?
Yes
No
Tuesday, January 12th, 2010 AT 10:14 AM

Please login or register to post a reply.

Recommended Guides