Buick Centry- Starter

Tiny
AEGONZO
  • MEMBER
  • BUICK CENTURY
2002/3.1/Limited/45,000. When I go to start the car I get a double clicking sound and the car does not start. I also at least once during starting will have all the dials in the dash flicker from one side to the other. I have checked the headlights while turning the ignition to make sure its not my battery. The car will usually start after a dozen times or so turning the ignition. Just now I tried to start the car, and after the second try all power was lost. No Power anywhere. Could this be just my starter, or that and something else? :Oops:
Do you
have the same problem?
Yes
No
Monday, November 19th, 2007 AT 8:45 AM

2 Replies

Tiny
FISHERMAN
  • MEMBER
Hello !
Looks to me like you have a bad connection on the battery.

Check both connectors, remove them and clean the posts and terminals be sure that you have a solid clean contact on both ends.

Also check the ground cable on the frame and on the engine and check the battery for holding and cranking capacity.

That should do the trick.

Anyhow if the problem its not there let us know to continue with the troubleshooting.

BTW thanks a Lot for your Donation we appreciate that!

Good Luck and let us Know!
Was this
answer
helpful?
Yes
No
Monday, November 19th, 2007 AT 3:37 PM
Tiny
BOOTDOG
  • MEMBER
I would first have the battery voltage checked anyway. If thats ok look for loose connections and corrosion then you can move to the starter if all else checks good. Have a helper turn the key while you tap on the starter with a hammer to see if it engages. I still suspect the battery. Advance auto will check the battery and charging for free. So try jumping the car. Good luck :wink:
Was this
answer
helpful?
Yes
No
Monday, November 19th, 2007 AT 3:38 PM

Please login or register to post a reply.

Recommended Guides