HVAC blower motor not working properly

Tiny
MIKEBAR18
  • MEMBER
  • 2013 FORD F-150
  • 3.5L
  • V6
  • TURBO
  • 4WD
  • AUTOMATIC
  • 107,000 MILES
The blower motor cycles on and off but it never ramps all the way to full speed. None of the speeds work. I have replaced blower motor controller, blower motor and relay. Does the signal wire coming from the HVAC module suppose to have 12 volts?
Do you
have the same problem?
Yes
No
Tuesday, June 1st, 2021 AT 3:59 AM

3 Replies

Tiny
DANNY L
  • EXPERT
Hello, I'm Danny.

There are two things I would check for the blower motor condition you are experiencing. You should check both the blower motor resistor and blower motor speed control that are both mounted to the under dash hvac box. Here is a tutorial showing how to test for electrical wiring:

https://www.2carpros.com/articles/how-to-check-wiring

I would check the wiring harnesses for corrosion, being melted, or burnt. I've attached picture steps below on how to replace both the blower motor resistor and speed control including their location on your truck. Hope this helps and thanks for using 2CarPros.
Was this
answer
helpful?
Yes
No
Tuesday, June 1st, 2021 AT 4:51 AM
Tiny
MIKEBAR18
  • MEMBER
From the research I was doing there is only the blower motor controller. I have changed it with a motorcraft one.
Was this
answer
helpful?
Yes
No
Tuesday, June 1st, 2021 AT 5:02 AM
Tiny
DANNY L
  • EXPERT
Hello again,

I can get more information about you truck if you can provide me with the last 8 digits of your VIN- vehicle identification number. Your truck does have a blower motor resistor and I've attached a picture of the Ford part number below. Let us know and we'll go from there. Hope this helps and thanks again for using 2CarPros.

Danny-
Was this
answer
helpful?
Yes
No
Tuesday, June 1st, 2021 AT 8:10 AM

Please login or register to post a reply.

Sponsored links