Blend door actuator?

Tiny
JAYBORT
  • MEMBER
  • 2003 FORD F-150
  • 5.4L
  • V8
  • 4WD
  • AUTOMATIC
  • 2,030,000 MILES
My air wasn’t getting very cold anymore, but I just changed all engine A/C related parts. I figured it would be the blend door actuator, so I took out the old one and put in the replacement. Now all of a sudden, I have no functionality to it, it will not move from hot to hold. I’ve already replaced my blend door and it’s free and works just fine, but the actuator has no movement. My fuses seem to be all time and I tried recalibrating the actuator and still nothing.
Do you
have the same problem?
Yes
No
Friday, September 2nd, 2022 AT 4:04 PM

3 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi,

It is possible that the new actuator is faulty. If you purchased it online, I have been seeing a lot of faulty parts.

Try this and let me know the results. Simply remove the actuator from the HVAC box. Don't disconnect the actuator from power. With it out, see if it responds when you change the temp request from heat to cool and opposite.

Also, make sure the actuator shaft is connected and doesn't come off when installing it.

Let me know what you find.

Joe
Was this
answer
helpful?
Yes
No
Friday, September 2nd, 2022 AT 10:02 PM
Tiny
JAYBORT
  • MEMBER
With the actuator out it still has no response, in fact I ve bought another actuator already just in case and it also has no functionality.
Was this
answer
helpful?
Yes
No
Saturday, September 3rd, 2022 AT 8:12 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi,

Is there a black wire in the wiring harness? If so, check it for continuity to ground. Also, disconnect the plug and see if there is power to the connector.

Here is a link you may find helpful:

https://www.2carpros.com/articles/how-to-check-wiring

Let me know what you find.

Joe
Was this
answer
helpful?
Yes
No
Sunday, September 4th, 2022 AT 7:07 PM

Please login or register to post a reply.

Sponsored links