Anti-theft activated

Tiny
CMCNABB77
  • MEMBER
  • 2011 GMC YUKON
  • 5.3L
  • 5 CYL
  • 4WD
  • 200,000 MILES
Truck is in anti-theft lock. I tried to rest doing the three on and off for 30 minutes methods. My problem is the light never went out to do step two over. Does this mean the anti-theft module is bad?
Do you
have the same problem?
Yes
No
Friday, May 21st, 2021 AT 11:37 AM

3 Replies

Tiny
KASEKENNY
  • EXPERT
This could be a umber of things so we need to start with checking for codes.

https://www.2carpros.com/articles/checking-a-service-engine-soon-or-check-engine-light-on-or-flashing

If there are no codes, then we are going to have to run through the testing below for this issue. It could be an issue with the BCM or even the IPC so we just need to see what turns up with this and we can go from there.

Let us know if you have questions. Thanks
Was this
answer
helpful?
Yes
No
-1
Saturday, May 22nd, 2021 AT 5:30 PM
Tiny
CMCNABB77
  • MEMBER
I did the test you sent with no luck. I order the scanner you mentioned and it reads no codes or failures. The security light does not blink when trying to start. It remains on. I tried everything I can think to try. Could it just be the chip in my key is bad? My fob will unlock and lock. Also set the alarm. Seem like it's the key maybe? Thank you for the help i'm lost here!
Was this
answer
helpful?
Yes
No
Tuesday, May 25th, 2021 AT 7:48 PM
Tiny
KASEKENNY
  • EXPERT
Okay. It could be a key issue but let's take a step back. The process that you laid out I think is for the wrong system. You have a Passkey III system so I attached the info below on this process.

Let's try this and and go from there.
Was this
answer
helpful?
Yes
No
Wednesday, May 26th, 2021 AT 6:00 PM

Please login or register to post a reply.

Sponsored links