1999 Acura TL Stall issue

Tiny
FLORIDABOB
  • 1999 ACURA TL

Electrical problem
1999 Acura TL 6 cyl Front Wheel Drive Automatic 146, 00 miles

Have had several occurances with an engine stall.

While driving, the "green key icon" for the immobilizer system come on. Within a minute the car will shut off. It will not start for several minutes, and then it will be fine.
This has happened 3 times over the course of several weeks.

I checked the owners manual, which warned about having another key with a computer chip too close to the key in the ignition. None near.
This has the factory key, that I have used for years with no issues.

Do you
have the same problem?
Yes
No
Monday, August 31st, 2009 AT 5:56 AM

3 Replies

Tiny
KHLOW2008
  • EXPERT
  • 41,940 POSTS

Hi floridabob,

When problem occurs and engine stalls, were the dash lights showing?

If not, the igntion switch could be intermittently failing.

There was a safety recall on the ignition switch. Call your local Acura dealer for more details.

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
Tuesday, September 1st, 2009 AT 1:04 PM
Tiny
FLORIDABOB
  • MEMBER

The stalling has happened three times, only with my wife driving alone (GREAT)
She says that when it stalls, the only dash lights that stay on are:
1. Green key icon
2. The maintanence required icon.

Was this
answer
helpful?
Yes
No
Tuesday, September 1st, 2009 AT 5:05 PM
Tiny
KHLOW2008
  • EXPERT
  • 41,940 POSTS

Yes, that confirms the ignition switch as the culprit.

Call the dealer to enquire if your vehicle is eligible for the recall.

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
Wednesday, September 2nd, 2009 AT 9:23 AM

Please login or register to post a reply.

Related Engine Stall Questions

Help us by donating