1999 Acura TL Car start but Stall

Tiny
CHAO_ZU
  • MEMBER
  • 1999 ACURA TL
Engine Performance problem
1999 Acura TL 6 cyl Two Wheel Drive Automatic 300km miles

Hi guys, I'm new to this post and trying to navigate around the site still.
i have a 99 tl with nearly 300k on it now. Recently when I start the car, it starts but it idols really sometimes and even stall the car at times.
this especially when the engine is hot. For example I drive it on the highway for an hour then have lunch if weather is hot outside the car has a hard time stay running, I have to give it some gas for a few seconds until it idols normally before I leave again.
I have already cleaned the throttle body. Hope you guy can help

Thanks in advance
Do you
have the same problem?
Yes
No
Thursday, March 25th, 2010 AT 11:17 PM

9 Replies

Tiny
KHLOW2008
  • EXPERT
Hi chao_zu,

What is the idling speed after warming up the engine?

Did you clean the Idle Air control valve?
Was this
answer
helpful?
Yes
No
Saturday, March 27th, 2010 AT 4:32 PM
Tiny
CHAO_ZU
  • MEMBER
In the morning when I start the car (when the engine is cold), its between 1500-2300 after a few mins its warmed up, its just under 1000. Same if I have the problem and give it gas for a few secs, it stabilizes just under 1000.
And the IACV was supposedly cleaned by the dealer through the throttle body (cause they told me theres a bypass under the throttle body that goes to the IACV)
Was this
answer
helpful?
Yes
No
Monday, March 29th, 2010 AT 9:58 AM
Tiny
KHLOW2008
  • EXPERT
The idling speed seems correct and yes, the IACV is under throttle body.

Did cleaning them improved on the stalling issues?
Was any other repairs carried out to fix this problem?
When did the problem start occurring?
Was this
answer
helpful?
Yes
No
Monday, March 29th, 2010 AT 4:37 PM
Tiny
CHAO_ZU
  • MEMBER
I personally don't believe cleaning the IACV helped, because the 3rd day it was cleaned it stalled again. The dealer believe it MIGHT have gone bad and want to replace it. It hasnt been replaced and the weather has stayed pretty cool for the last week or so. I havnt had the problem but the weather is getting warmer and i'm afraid it will happen any time now.
The car drives just fine, no other issues as far as I know.
And this problem happened once in jan and didnt think too much of it, and at least 5 or 6 times near the end of feb and beginning of march.
Was this
answer
helpful?
Yes
No
Tuesday, March 30th, 2010 AT 9:14 AM
Tiny
KHLOW2008
  • EXPERT
If the idling speed is stable most of the time, about 700 rpm, then cleaning the IACV would not help. If the IACV is dirty, the idling speed would drop or surge when the AC is turned ON.

For some models the MAP sensor is known to cause stalling but that is mostly during cold start.
Was this
answer
helpful?
Yes
No
Tuesday, March 30th, 2010 AT 9:37 AM
Tiny
CHAO_ZU
  • MEMBER
Yes the idling speed is stable most of the time. When the car is warm. Another mechanic thought it might be the egr. The exhaust gas re something. Could that be it?
Was this
answer
helpful?
Yes
No
Tuesday, March 30th, 2010 AT 9:56 AM
Tiny
KHLOW2008
  • EXPERT
EGR fault would result in misfiring and erratic running but is seldom the cause for stalling. If it is the case, trouble codes would be recorded.
Was this
answer
helpful?
Yes
No
Tuesday, March 30th, 2010 AT 10:29 AM
Tiny
CHAO_ZU
  • MEMBER
I see. My check engine light is on but its for some kind of vapor thing in/around the gas tank. But I dont think that has anything to do with it.
Was this
answer
helpful?
Yes
No
Tuesday, March 30th, 2010 AT 10:35 AM
Tiny
KHLOW2008
  • EXPERT
What is the exact trouble code?
Was this
answer
helpful?
Yes
No
Tuesday, March 30th, 2010 AT 11:18 AM

Please login or register to post a reply.

Recommended Guides