Service engine soon message and locks into gears normally but no acceleration

Tiny
CARDUMBPLZHELP
  • MEMBER
  • 2004 BUICK RENDEZVOUS
  • 3.4L
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 90,040 MILES
The vehicle starts up but idles extremely rough sputtering and shutting off, the car simply wont move it shifts and locks into gears normally but no acceleration when gas is pressed. I can feel it jar just slightly as if it wants to go but it doesn't. The dash has a brake light on and also service engine soon. I have changed the transmission solenoids and also the transmission oil and that's not solving my issue. What next? I don't not have a readed tool to check codes. Any help is a appreciated greatly thanks in advance.
Do you
have the same problem?
Yes
No
Monday, September 28th, 2020 AT 4:49 AM

1 Reply

Tiny
DANNY L
  • EXPERT
Hello, I'm Danny.

With your car running poorly like that and the check engine light on that definitely means a fault code is stored in your vehicles computer. Since you don't have access to a scanner or code reader you can take your car to a local AutoZone auto parts store and they can check for free. Here is a tutorial showing showing what is involved for checking codes:

https://www.2carpros.com/articles/checking-a-service-engine-soon-or-check-engine-light-on-or-flashing

Once you have this performed then get back to us with the code or codes numbers and we can then properly diagnose. Hope this helps and thanks for using 2CarPros.
Was this
answer
helpful?
Yes
No
-1
Monday, September 28th, 2020 AT 12:28 PM

Please login or register to post a reply.

Sponsored links