Acceleration problem

Tiny
SHELBY45
  • MEMBER
  • 2006 FORD FUSION
  • AUTOMATIC
  • 58,000 MILES
I got onto the highway and tried to accelerate and the car would not go above 35 mph. The engine was making a loud noise and then the engine light came on. It does not blink or go off at all. Any time I start the car the engine light is on.
Do you
have the same problem?
Yes
No
Thursday, December 6th, 2018 AT 11:24 AM

1 Reply

Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi and thanks for using 2CarPros.

If the check engine light is staying on with the engine running, there are diagnostic trouble codes stored in the computer to help diagnose the problem. Therefore, you need to scan the computer so we can get a better idea where the problem is coming from.

Here is a quick video that shows how to scan a computer:

https://youtu.be/YV3TRZwer8k

I realize most people do not own a scanner. However, most parts stores will do it for free. Therefore, if you can safely get it to one that does it, you can try that. If you cannot, see if they will lend or rent one to you. Honestly, if it is making a lot of noise, I do not want to chance causing more damage.

If you cannot get a scanner and it is making a lot of noise, it may be cost effective to have it towed to a place where it can be scanned.

Once you get the codes from the computer, let me know what they are and I can guide you.

I hope this is helpful. Let me know if you have other questions.

Take care,
Joe
Was this
answer
helpful?
Yes
No
Thursday, December 6th, 2018 AT 8:02 PM

Please login or register to post a reply.

Recommended Guides