Brake lights not working

Tiny
KENNETH BROWN JR
  • MEMBER
  • 2014 KIA OPTIMA
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 81,000 MILES
The third brake light (middle) comes on, but the two side brake lights do not.
All the rear bulbs are working as I tested all of them (turning nighttime lights
on, turning on hazards, etc.). But the side rear lights do not illuminate more
when I press the brakes.
i checked the fuses, they're all fine. I also replaced the brake switch and still get the same results the harness connection where the bulbs go in are not corroded either I don't know where else to look I checked with a meter and I'm still getting power.
Any tips would be helpful. Thank you for the time.
Do you
have the same problem?
Yes
No
Thursday, January 6th, 2022 AT 1:41 PM

1 Reply

Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi,

I attached the wiring schematic for the exterior lighting circuits. I highlighted wiring for the brake lights. I need to better understand something.

You indicated you are still getting power. Do you mean the brake light socket has a power signal when the brake lights should turn on? If that is the case, confirm there is continuity to ground at the socket (black wire). I wasn't thinking that could be possible because the left and right lights have two different ground points. Also, here is a link you may find helpful:

https://www.2carpros.com/articles/how-to-check-wiring

Let me know.

Joe

See pics below.
Was this
answer
helpful?
Yes
No
Thursday, January 6th, 2022 AT 6:05 PM

Please login or register to post a reply.

Sponsored links