Heater blows out cold air

Tiny
DALLAS COX
  • MEMBER
  • 2011 NISSAN ARMADA
  • V8
  • 2WD
  • AUTOMATIC
  • 57,000 MILES
At the first cold spell I turned on the heater, but it blows out only cold air. The vehicle only has 57,000 miles ad all appears to be normal. There's just no heat. I added anti-freeze, attempted to change the fuse, but the fuse panel cover illustration doesn't appear to match the actual fuses, not to mention the fuses are next to impossible to put back in. I am attempting to "bleed" the system now by removing the radiator cap, running the vehicle with the heater on max. No change after 20 minutes or so. Help, thanks.
Saturday, November 30th, 2013 AT 7:11 AM

3 Replies

Tiny
SATURNTECH9
  • MECHANIC
  • 30,869 POSTS
Are both the heater hoses going into the firewall going into the firewall getting too hot to hold when the engine is at operating temp?

Those cars had a problem with the blend door actuator which controls the temperature.
Was this
answer
helpful?
Yes
No
+6
Saturday, November 30th, 2013 AT 7:35 AM
Tiny
KEN L
  • MASTER CERTIFIED MECHANIC
  • 43,639 POSTS
Here is a diagram for how to replace the temperature blend door actuator. Also disconnect the battery for 5 minutes to reset the system, this could reboot the climate control and get it working.

Here is a guide to help you see what you are in for when doing the job

https://www.2carpros.com/articles/replace-blend-door-motor

Check out the diagrams (Below)

Please let us know what you find.

Cheers, Ken
Was this
answer
helpful?
Yes
No
+1
Tuesday, November 22nd, 2016 AT 11:14 AM
Tiny
DALLAS COX
  • MEMBER
  • 1 POST
It took me a bit but I got the temp actuator replaced and the system blows heat again ya! Great site BTW
Was this
answer
helpful?
Yes
No
+1
Tuesday, November 22nd, 2016 AT 5:50 PM

Please login or register to post a reply.

Sponsored links