HELLO ALL IM HAVING A COUPLE OF MINOR ISSUES AND...

2011 Dodge Avenger

Tiny

fpj66

November, 9, 2012 AT 1:48 PM

Hello all, I'm having a couple of minor issues and 1 major issue with my avenger. First off, every time I shut my car off, the front part makes a tick tick tick noise. It does it every time, unless im on the road driving for 2 plus hours. Then it wont make a noise. But if I get in it and start it up then Shut it off it'll do it. I thought it had something to do with the battery, but the battery is in the trun. Next minor issue is my high beam indicator, it'll come on my dash board one day, then the next time I try to use it, its gone and won't show up for weeks, then itll start working again for a few days. My main concern is when I shift. This started happening about a day ago. When I shift from reverse to drive and vice versa the car makes a very loud click noise. Like when u flick your tongue in ur mouth, just really loud. I started hearing this yesterday. Since then I've noticed I don't shift so smoothly when I go to second gear. Can u guys help me out? Thank you for your expertise.

FOUND 700 RELATED QUESTIONS

4 Answers

Tiny

hmac300

November, 9, 2012 AT 2:52 PM

The tick may be exaust system not heating up fully then cooling down, have the car scanned for codes for trans problem and check the grounds on the car for corrosion.

Tiny

fpj66

November, 9, 2012 AT 3:08 PM

Will do thank you

Tiny

fpj66

November, 9, 2012 AT 3:09 PM

Will do thank you

Tiny

hmac300

November, 9, 2012 AT 3:57 PM

Jsut thought of something this shold be covered under warranty anyhow.

Please login or register to post a reply.

Brake Light Bulb Replacement Mercedes Benz
Side Marker Bulb Replacement Mini Cooper
Reverse Light Bulb Replacement Chevrolet
Brake Light Bulb Replacement Mercedes Benz ML