Instrument cluster won't come on

Tiny
ANONYMOUS
  • 2010 CHEVROLET EQUINOX
  • 51,000 MILES

Instrument cluster won't come on. Car runs, lights function. Haven't found a bad fuse. Radio functions. I have a 290 mile trip over snoqualmie pass to get home today (sunday). Need this working.

Sunday, January 27th, 2013 AT 8:11 PM

3 Replies

Tiny
2CARPROS KEN
  • ADMIN
  • 11,720 POSTS

There are two fuses the run the instrument cluster that I would check first. If okay make sure the cluster is getting power and ground. Here are two guides to help you run the tests.

https://www.2carpros.com/articles/how-to-check-a-car-fuse

and

https://www.2carpros.com/articles/how-to-use-a-test-light-circuit-tester

If the fuse and connections seem okay it will be the cluster itself that needs replacement which is common. Here is a video of the job being done so you can see what it will be like. (video below)

https://youtu.be/_HEC44xENxw

Here are the fuse panel and instrument cluster wiring diagrams to help you see what's going on. (Below)

Let us know what happens and please upload pictures or videos of the problem.

Cheers, Ken

Was this
answer
helpful?
Yes
No
Thursday, November 9th, 2017 AT 2:01 PM
Tiny
NICKDGX
  • 2009 CHEVROLET EQUINOX
  • 97,000 MILES

What fuse do I check if my gauges are not working? I reset my oil life and the next time started the vehicle my gauges did not work on my dash!

Was this
answer
helpful?
Yes
No
Thursday, November 9th, 2017 AT 2:02 PM (Merged)
Tiny
HMAC300
  • EXPERT
  • 49,778 POSTS

It shold be in your manual or marked on cover of fuse box but should be fuse 18 on dash fuse box

Was this
answer
helpful?
Yes
No
Thursday, November 9th, 2017 AT 2:02 PM (Merged)

Please login or register to post a reply.

Recommended Guides