Engine stalls

Tiny
RACHAEL NOTFORYOU
  • MEMBER
  • 2007 CHEVROLET TAHOE
  • V8
  • 4WD
  • 176,543 MILES
I went to Aamco to bring in my SUV because my service stabili-trak came on with my check engine light. It came on after I came home from work but my car worked fine before that light came on. The next day when I left for work when my car is sitting at the light it started to shake then sitting it cut off with the car still in drive. I had to turn off my engine and put it in park then turn it back on and it started back up. But still when idling it shakes. I took it up to Autozone so they can read the code. It said misfire in cylinder six. I had my mechanic look at it and switched the coil that was three and six I believe. After that the code did not say that anymore like three others came on one said a map sensor. After he switched them back the car would not start now it was saying no oil pressure. When the car sat at the first click you can here the fuel pump start I think he said. The dash said low engine power as well. I took it up to Aamco basically saying it was a oil pressure switch so they supposedly fixed it $364.00. Later it ran for two days now it will not stay started the engine starts, but shuts off and it smells like gas on the inside. After listening to this guy saying your car is still going to misfire because you need a tune up spark plugs. So I changed them the car is still misfiring I already put new coils on as well. My mechanic cannot figure out what is wrong. I am looking online can you help me please?
Do you
have the same problem?
Yes
No
Monday, January 16th, 2017 AT 6:33 PM

4 Replies

Tiny
KEN
  • ADMIN
Hi RACHAEL,

This sounds like you have a crankshaft angle sensor that has failed or is failing, here is a guide to help you get the problem fixed.

https://www.2carpros.com/articles/crankshaft-angle-sensor-replacement

Please let us know what happens so it will help others.

Best, Ken

Was this
answer
helpful?
Yes
No
Saturday, January 21st, 2017 AT 1:45 AM
Tiny
RACHAEL NOTFORYOU
  • MEMBER
Ok so now after attempting to start it it runs really ruff it starts now but it misfires really bad my oil pressure sensor keeps going up and down it never used to do that if I drive it to long it smells like gas and when I stop the oil pressure goes down. Now I also put gas in I drove to school today and work it was a line before e and its going down really fast and when u turn the car off it smells like gas as well. I had it sitting for a couple of days and started it to see if I dont drive it will help. I had to step on the gas when I start it and it acts like it hesitates then turns on and shakes? When I get about 55 it doesnt misfire?
Was this
answer
helpful?
Yes
No
Tuesday, January 24th, 2017 AT 2:52 PM
Tiny
RACHAEL NOTFORYOU
  • MEMBER
Also my check engine light is still blinking when I try to turn to the right it acts like it doesnt want to turn it skips but if I park and turn to the left its not as bad. Stupid stabiltrak light is on I do not want to take it to the dealer for people to guess whats wrong I need a deffinate answer. One dealership said it might be a bad something inside the engine I think a piston or the wring or something idk. I live in mn and the dealer charges 140 to diagnose it I just need an anwser and what to tell this dealer so I dont look stupid and explain to him I need a compression test so if the compression is low they say its so many different things
Was this
answer
helpful?
Yes
No
Tuesday, January 24th, 2017 AT 3:02 PM
Tiny
KEN
  • ADMIN
Hey RACHAEL,

We need to see if the engine has good compression in all cylinders before we go any further. Please follow this guide and report back with the results.

https://www.2carpros.com/articles/how-to-test-engine-compression

Best, Ken

Was this
answer
helpful?
Yes
No
Wednesday, January 25th, 2017 AT 2:38 AM

Please login or register to post a reply.

Recommended Guides