THROTTLE PROBLEMS

2006 Suzuki Swift

Tiny

jewls4u1976

March, 19, 2012 AT 9:12 PM

Hi, I have a 2006 suzuki swift.I don't think my throttle plate is functioning. I am having high rpms when accelerating and Bouncing needle at coasting.I checked and cleaned the throttle plate it doesn't seem to close all the way and it is not opening when you press on the gas when the car is in off position.(Which it should open) When the car is running, on acceleration it dose open quarter way. I down loaded a repair manual on line but it wasn't the right model which it said it was. I don't want to spend another 30 bucks on another one. What could be the problem? Cable? Where is that located? There are no codes.

FOUND 81 RELATED QUESTIONS

5 Answers

Tiny

KHLow2008

March, 19, 2012 AT 9:23 PM

If the throttle is not opening, you would not be able to get high rpm and accelerate. Throttle is electronically controlled and requuires the various sensors to be sending signals to the computer to control its movement. Looking at it is not the correct way.

One of the best way is to plug in a scan tools and monitor its movement.

High engine rpm can indicates a slipping transmission. Do you have coolant losses issues?

Tiny

jewls4u1976

March, 19, 2012 AT 9:39 PM

No coolant loss, RPMS are OK at idle. It could be slippage. But it seams smooth. No clonks, Watching the rpms it seems to shift when need. Except When I was driving the other day I accelerated fast to get up to 100 kl. It shifted but then the needle sat at 4000 rpms. It didn't want to kick over. I had to let off the gas for it to. Small engine. Compression test was 180 all across. My concern is the throttle plate not closing all the way and not opening? New plugs. No external oil leaks.

Tiny

KHLow2008

March, 19, 2012 AT 9:54 PM

This vehicle response to throttle openings and vehicle speed so if you are accelerating hard, the rpm would remain high until it is due for gear change. I am not sure if you really have a problem as I do not know the exact situation.

Tiny

jewls4u1976

March, 20, 2012 AT 1:50 AM

Car 2006 Suzuki Swift Automatic, 1.6 engine, hatchback.129,000klm.
Issues: 1. Poor or no Braking in reverse on cold engine.
2. Throttle butterfly valve not fully closing (loose)
3. Butterfly valve wont open when gas peddle depressed car engine not running. Opens a quarter way when running and accelerated.
4. RPMS got stuck at 4000 rpms when quick to accelerate to 100klh, might be a up shifting delay
5. Continuing Bouncing, dropping RPM Needle when coasting.
6. Car seems to have little power and kicks in sometimes.

So you think think that this may be normal?

Normal Idle
Good compression
No Codes Present
New plugs

Tiny

KHLow2008

March, 20, 2012 AT 1:50 PM

Poor braking only in reverse?

Throttle is fly by wire, it does not close fully when engine is stopped. Gas pedal does not necessarily mean it will open fully when accelerator is depressed with engine not running. I don't see any problem with that.

RPM getting stuck at 4k rpm. I am not sure what the exact situation is so am ot able to comment on this.

Poor performance I can understand but sometimes kick in, that have me scratching my head.

Please login or register to post a reply.

Easily Clean Your Throttle Bore Like a Pro
Air Filter Replacement Ford Taurus
Air Filter Replacement
Engine Oil Change and Filter BMW 5 Series
Engine Oil Change and Filter Mercedes