Car will not start, no spark to plugs.

Tiny
GOINGHOMENO
  • 2006 MITSUBISHI GALANT
  • 70,000 MILES

Car turned off while driving, got a jump drove home and car will not start. Car sounds like it wants to start. Replaced the crankshaft sensor put car together and it started but sounded rough at idle after about 2min. Car turned off. Restarted car 3 times and each time it turned off. Now it's back to it will not start status and no spark is going to the spark plugs. What can I do next to fix the problem?

Do you
have the same problem?
Yes
No
Saturday, September 10th, 2011 AT 8:07 AM

4 Replies

Tiny
KHLOW2008
  • EXPERT
  • 41,939 POSTS

Which engine do you have?

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
-1
Saturday, September 10th, 2011 AT 12:44 PM
Tiny
GOINGHOMENO
  • MEMBER

2.4L 4cyl

Was this
answer
helpful?
Yes
No
Sunday, September 11th, 2011 AT 5:36 AM
Tiny
KHLOW2008
  • EXPERT
  • 41,939 POSTS

Apart from the Crank Position Sensor, the Cam Position Sensor and other components as listed in the diagram are related to the ignition system.

Is there any trouble codes? What was the reason for replacing the Crank Position Sensor? Did you check the MFI relay?

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
-2
Sunday, September 11th, 2011 AT 6:30 AM
Tiny
KHLOW2008
  • EXPERT
  • 41,939 POSTS

Sorry for missing out the diagram.

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
Sunday, September 11th, 2011 AT 6:31 AM

Please login or register to post a reply.

Related Engine No Start Questions

Help us by donating