Automatic lock not working

Tiny
JEANJ4826
  • 2006 CHRYSLER TOWN AND COUNTRY
  • 4 CYL
  • 53 MILES

My lock on the sliding passenger side door isn't working when I use the button to unlock all of the doors. How do I fix this? Is it a fuse or do I need to take it to a shop? I think something is also wrong with the vent window in back on that same side. Could the problems be connected?

Do you
have the same problem?
Yes
No
Tuesday, August 2nd, 2011 AT 4:30 PM

4 Replies

Tiny
GLADSONLY
  • MEMBER

I'm not a mechanic, but have exact same problem. Let me know if you get an answer.

Was this
answer
helpful?
Yes
No
Sunday, August 21st, 2011 AT 12:02 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
  • 68,323 POSTS

If the others work, chances are it isn't a fuse. You need to remove the door panel to see if there is power to the lock solenoid. If there is, the solenoid is most likely bad. If there is no power, you need to trace the power supply back to find where the power is lost.

Was this
answer
helpful?
Yes
No
Please consider a donation if we helped you
Saturday, October 8th, 2011 AT 4:50 AM
Tiny
CALDOG41
  • MEMBER

I also had this problem and can tell you that the door lock control? Had to be replaced. I ended up going with a used part because NO ONE had a new part in stock! I have intermittent problems with this one too.

Was this
answer
helpful?
Yes
No
Friday, October 28th, 2011 AT 5:47 PM
Tiny
CADIEMAN
  • MEMBER

Youll need to check the lock acuator in the door. It maybe a bad lock acuator or a loose rod going to the lock assy.

Was this
answer
helpful?
Yes
No
Friday, October 28th, 2011 AT 6:45 PM

Please login or register to post a reply.

Related Door Lock Auto Locking Questions

Recommended articles