2005 Impala hard start, stumble/hesitation on hard accel

Tiny
DISCOMBOBULATED
  • MEMBER
  • 2005 CHEVROLET IMPALA
  • 150,000 MILES
The car is hard to start after a cold soak. It takes 4 - 6 tries to get it started. Fuel pump and filter have been replaced, due to filter leaking, and low pressure from the pump. It is acting like the pump has lost its prime, I replaced the pump again. It still has the same issue. I used a Delphi pump both times.

Under normal driving the car runs/drives fine, until quick acceleration is needed. It then hesitates and feels about half power.

I tested the TPS and found a dead spot in it almost at WOT. I replaced it and it did not help the problem.

It has the following codes set:
P0128
P0135
P0401 (recurring after clearing codes)
P0131

Your help is greatly appriciated.
Do you
have the same problem?
Yes
No
Wednesday, September 18th, 2013 AT 6:25 PM

2 Replies

Tiny
ASEMASTER6371
  • EXPERT
I would look at the fuel pressure regualtor for any fuel in the vacuum line. Very common failure.

Clearing codes does nothing. The issue will stay till the failure is identified and repaired. Codes never identify bad parts, just failed systems.

128 is a thermostat failure.
131-135 are O2 heater codes.
401 is an egr issue.

Roy
Was this
answer
helpful?
Yes
No
Friday, March 12th, 2021 AT 9:39 AM
Tiny
DISCOMBOBULATED
  • MEMBER
This car is still giving me problems starting, and is now running rough and dying when coming to a stop. The fuel pressure regulator was replaced when this problem started. The car has about 152k on it. Thanks again for your help.
Was this
answer
helpful?
Yes
No
Friday, March 12th, 2021 AT 9:39 AM

Please login or register to post a reply.

Sponsored links