OIL LIGHT

  • Tiny
  • Cdooley
  • 2005 CHRYSLER PT CRUISER
  • 4 CYL
  • FWD
  • AUTOMATIC
  • 74,000 MILES

My 2005 P/T cruiser 74,000 miles just recently, when I start the engine, the oil light stays on, I restart the engine, oil light goes out. It doesn't need oil, I change oil regularly. Is it saying faulty oil pump? Or is it faulty sensor light?

Do you
have the same problem?
Yes
No
Thursday, February 17th, 2011 AT 3:03 PM

1 Reply

  • Tiny
  • ImpalaSS
  • EXPERT
  • 3,148 POSTS

Hello

To better assist you, I know you said your model was an LX, but what I show is either just the PT Cruiser, or the GT, Limited or Touring do you know which one of these. Also what is your engine size in liter?

Next glad you checked your oil PLEASE make sure you continue to do that. I would think it is more the switch than the pump. Not ruling it out . Just seems more normal it is the switch.

Please go to Auto Zone (AZ) or O Reilly s (OR) and have them pull your codes to see if it threw one on the switch. They may hesitate if your check engine light didn t come on but let them know it went on then off. I want to check to see if it threw any codes please make sure you tell us exactly what the code was, number and all. Example, if the code was E0568 O2 Sensor bad. Then make sure you give us all of that.

You might also check the wiring on the switch to make sure it has a good connection, not wet, corroded etc.

Let me know the above most likely I will suggest a switch change.

Was this
answer
helpful?
Yes
No
Thursday, February 17th, 2011 AT 3:40 PM

Please login or register to post a reply.

Other Oil Light Questions