Transfer case not working right

Tiny
JOHN T360
  • MEMBER
  • 2005 CHEVROLET COLORADO
  • 120,000 MILES
4 wheel drives jump to 4 wheel drive while driving. Has tire noise but not tires.
Do you
have the same problem?
Yes
No
Thursday, January 5th, 2012 AT 5:04 PM

18 Replies

Tiny
DRCRANKNWRENCH
  • MECHANIC
  • 3,380 POSTS
I am providing you with the wiring diagram for the four wheel drive actuation system. Near the bottom you will note the actuator motor and the transfer case encoder motor. You may have a short or bad ground in one of these components. Check wires for good fit and bare spots where insulation is missing and could cause a short. Also check all grounds for a tight corossion, rust, free fit that is metal to metal. I f all the wires seem good the actuator is the first things I would be suspect of.
Take the truck and have the trouble codes pulled. Any Advance Auto or Auto Zone will do this for free.
If no codes come up there is a mechanical problem that may be in the hubs. Take them off and clean and re-grease them while checking for broken or mal-functioning components.
The ECU may be at fault is all othere possibilities are eliminated, but this is unlikely. Check the ground for it as well as the main power wire.
Was this
answer
helpful?
Yes
No
+1
Friday, January 6th, 2012 AT 3:36 AM
Tiny
RSKING03
  • MEMBER
  • 1 POST
  • 2004 CHEVROLET COLORADO
  • 6 CYL
  • 4WD
  • AUTOMATIC
  • 70,000 MILES
I have push button 4 wd but it all of a sudden stopped working the other day I have now idea what is wrong
Was this
answer
helpful?
Yes
No
Monday, November 12th, 2018 AT 8:01 AM (Merged)
Tiny
JACOBANDNICKOLAS
  • MECHANIC
  • 107,696 POSTS
What you need to check is to see if the 4wd actuator on the transfer case if getting power. If it is, chances are the actuator is bad. If there is no power, check for damaged wiring and the switch itself.
Was this
answer
helpful?
Yes
No
Monday, November 12th, 2018 AT 8:01 AM (Merged)
Tiny
JAMES.LAVER
  • MEMBER
  • 2 POSTS
  • 2004 CHEVROLET COLORADO
  • 100,000 MILES
It wont go into 4wd all the light does is blink
Was this
answer
helpful?
Yes
No
+1
Monday, November 12th, 2018 AT 8:02 AM (Merged)
Tiny
JACOBANDNICKOLAS
  • MECHANIC
  • 107,696 POSTS
Check to see if there is power to the 4wd actuator on the transfer case.
Was this
answer
helpful?
Yes
No
Monday, November 12th, 2018 AT 8:02 AM (Merged)
Tiny
JAMES.LAVER
  • MEMBER
  • 2 POSTS
What if there is power
Was this
answer
helpful?
Yes
No
Monday, November 12th, 2018 AT 8:02 AM (Merged)
Tiny
JACOBANDNICKOLAS
  • MECHANIC
  • 107,696 POSTS
Then you need to remove the actuator and check to see if it is working properly.
Was this
answer
helpful?
Yes
No
Monday, November 12th, 2018 AT 8:02 AM (Merged)
Tiny
WILLIAM DEAN
  • MEMBER
  • 2 POSTS
  • 2006 CHEVROLET COLORADO
  • 97,000 MILES
Truck makes clunking noise while in four wheel drive will not go into four low
Was this
answer
helpful?
Yes
No
Monday, November 12th, 2018 AT 8:02 AM (Merged)
Tiny
MHPAUTOS
  • MECHANIC
  • 31,938 POSTS
Sounds like a problem with the transfer, I feel that you will have to pull it out and dismantle the transfer and inspect for damage, drain oil first and check for any metal in the oil as well.
Was this
answer
helpful?
Yes
No
Monday, November 12th, 2018 AT 8:02 AM (Merged)
Tiny
WILLIAM DEAN
  • MEMBER
  • 2 POSTS
  • 2006 CHEVROLET COLORADO
  • 97,000 MILES
Truck goes into four wheel drive but makes a clunking sound and will not go into four wheel low
Was this
answer
helpful?
Yes
No
Monday, November 12th, 2018 AT 8:02 AM (Merged)
Tiny
HMAC300
  • MECHANIC
  • 48,606 POSTS
Check to see if oyoru solenoid is sticking or not workingthere is one on the t case and one ofn the axle.
Was this
answer
helpful?
Yes
No
Monday, November 12th, 2018 AT 8:02 AM (Merged)
Tiny
DARRINH
  • MEMBER
  • 1 POST
  • 2005 CHEVROLET COLORADO
  • 6 CYL
  • 4WD
  • AUTOMATIC
  • 46,000 MILES
When I push my 4 high button on the dash the light blinks but won't lock in. It has done this in the past but seemed to engage maybe after warming up.
Was this
answer
helpful?
Yes
No
Monday, November 12th, 2018 AT 8:02 AM (Merged)
Tiny
MASTERTECHTIM
  • MECHANIC
  • 4,749 POSTS
Its usually caused by a faulty 4wd encoder motor. This is the electric motor on the side of the transfercase. Try tapping on it for a temporary fix. Hope this helps
Was this
answer
helpful?
Yes
No
Monday, November 12th, 2018 AT 8:02 AM (Merged)
Tiny
WVRAM04
  • MEMBER
  • 3 POSTS
  • 2005 CHEVROLET COLORADO
  • 3.5L
  • 5 CYL
  • 4WD
  • AUTOMATIC
  • 127,000 MILES
I was using the 4x4 couple of weeks ago and then the lights on the 4x4 panel went out and that was it. It does say "Serv 4x4", I have replaced the actuator, transfer case module and today the control module under the driver's seat. I have checked the relays the fuses. The lights on the 4x4 panel light up in the start circuit but when it goes into the run circuit nothing. Help. Thanks
Was this
answer
helpful?
Yes
No
Thursday, March 28th, 2019 AT 11:51 AM (Merged)
Tiny
KEN L
  • MASTER CERTIFIED MECHANIC
  • 42,288 POSTS
It sounds like the system is not getting power. Lets check at fuse # 36 TCCM under the hood. Here are two guides and the transfer case wiring diagrams so you can see how the system works and the fuse location as well:

https://www.2carpros.com/articles/how-to-check-a-car-fuse

and

https://www.2carpros.com/articles/how-to-check-wiring

Check out the diagrams (below). Please let us know what you find. We are interested to see what it is.

Was this
answer
helpful?
Yes
No
Thursday, March 28th, 2019 AT 11:51 AM (Merged)
Tiny
WVRAM04
  • MEMBER
  • 3 POSTS
I feel really dumb for the reply. I took my vehicle to a garage to see if they could find out what the problem was and they put it on a computer and here it said the "Encoder motor". But the problem was the code needed to be cleared and I did disconnect the battery and I thought that would do it. They said it used to clear the codes but not anymore. Thanks for the help anyway.
Was this
answer
helpful?
Yes
No
Thursday, March 28th, 2019 AT 11:51 AM (Merged)
Tiny
KEN L
  • MASTER CERTIFIED MECHANIC
  • 42,288 POSTS
Good to hear, please use 2CarPros anytime we are here to help.
Was this
answer
helpful?
Yes
No
Thursday, March 28th, 2019 AT 11:51 AM (Merged)

Please login or register to post a reply.

Sponsored links