2004 Saturn L300 stalling

Tiny
CHRYSTYNAZ
  • MEMBER
  • 2004 SATURN L300
  • 145,000 MILES
I was driving down the road accelerating. Made a pop sound then as I let off the gas it stalled. Restarts but stalls as soon as you release the gas. Starts up good. And will go if I keep engined revved. But when my foot comes off gas the car stalls out
Do you
have the same problem?
Yes
No
Monday, August 19th, 2013 AT 6:56 PM

9 Replies

Tiny
SATURNTECH9
  • EXPERT
Do you have any codes in the computer? Has the timing belt ever been changed?Does then engine run good and have plenty of power other then wanting to stall at idle?Is the check engine light on while its running?
Was this
answer
helpful?
Yes
No
Monday, August 19th, 2013 AT 7:03 PM
Tiny
CHRYSTYNAZ
  • MEMBER
I dunno about codes. But no engine lights on when running. For the most part it runs very well. It has had the belt replaced and has had good maintenance upkeep. Everyonce in awhile it will shift hard sending it into saftey mode. I was told it most likely is the cadilac converter by a friend. I had it towed to my apartment
Was this
answer
helpful?
Yes
No
Tuesday, August 20th, 2013 AT 9:02 AM
Tiny
SATURNTECH9
  • EXPERT
The hard shifting is most likely a bad line pressure control solenoid very common on that car have replaced time on that car. As far as the other if it didn't have plenty of power you could have a plugged cat.
Was this
answer
helpful?
Yes
No
Tuesday, August 20th, 2013 AT 10:44 AM
Tiny
CHRYSTYNAZ
  • MEMBER
This morning I went to start my car just to see if it would stall. It stayed started for a few min and then stalled, however the engine light is now on. Everything has power and engine is not making any funny noises. It just keeps stalling
Was this
answer
helpful?
Yes
No
Wednesday, August 21st, 2013 AT 8:49 AM
Tiny
SATURNTECH9
  • EXPERT
We need to see what codes you have in the computer? Also when it stalls does it restart right away or do you have to wait before it will restart?Those cars also had issues with crankshaft position sensors.
Was this
answer
helpful?
Yes
No
Wednesday, August 21st, 2013 AT 9:57 AM
Tiny
CHRYSTYNAZ
  • MEMBER
When I unplug the air filter it doesn't stall. As soon as we plug it back in it stalls out
Was this
answer
helpful?
Yes
No
Wednesday, August 21st, 2013 AT 12:55 PM
Tiny
SATURNTECH9
  • EXPERT
So are you unplugging the mass air flow sensor on the air filter tube?Or unhooking the air filter tube going to the throttle body?
Was this
answer
helpful?
Yes
No
Wednesday, August 21st, 2013 AT 1:32 PM
Tiny
CHRYSTYNAZ
  • MEMBER
When I pop the hood the air filter is to the left in a casing. Has a plug there on top. I just unplugged that.
Was this
answer
helpful?
Yes
No
Wednesday, August 21st, 2013 AT 8:54 PM
Tiny
SATURNTECH9
  • EXPERT
That would be the mass air flow sensor. Get some mass air flow sensor cleaner remove the tube from around the mass air flow sensor. Then clean the sensor with the cleaner. See if it runs any better?I have replaced a lot of mass air flow sensors on those cars.
Was this
answer
helpful?
Yes
No
Wednesday, August 21st, 2013 AT 9:58 PM

Please login or register to post a reply.

Recommended Guides