3400, V6 engine, my BCM keeps going out, what would make it go out in 5 minutes

Tiny
JMMJBN
  • 2004 OLDSMOBILE ALERO
  • 137 MILES

I can replace the bcm, and go thru the process for the security light with the ign. Switch and it all sets up then after startin a time or two the bcm goes back like it was, all lights on dash and gauges come on for 3 seconds then go out and the tach and speedometer do not work. Can turn key on and jump across starter, it starts and runs and shifts fine, but no gauges or warning lights.

Do you
have the same problem?
Yes
No
Friday, October 12th, 2012 AT 5:07 PM

16 Replies

Tiny
KHLOW2008
  • EXPERT
  • 41,967 POSTS

Try checking for trouble codes. Check underhood fuses.

Was this
answer
helpful?
Yes
No
Friday, October 12th, 2012 AT 5:51 PM
Tiny
JMMJBN
  • MEMBER

All fuses are good, can not check codes, will not read codes

Was this
answer
helpful?
Yes
No
Friday, October 12th, 2012 AT 5:53 PM
Tiny
DOCFIXIT
  • EXPERT
  • 18,993 POSTS

Check for voltage on ignition feed connector B terminal 9 pink wire

Was this
answer
helpful?
Yes
No
Friday, October 12th, 2012 AT 5:57 PM
Tiny
KHLOW2008
  • EXPERT
  • 41,967 POSTS

Do you mean the scan tool is not able to communicate?

Was this
answer
helpful?
Yes
No
Friday, October 12th, 2012 AT 5:57 PM
Tiny
JMMJBN
  • MEMBER

Scan tool will not show anything, like nothing is there. What is voltage suppose to be on pink wire? Will have to get back to you later, as I am at work.

Was this
answer
helpful?
Yes
No
Friday, October 12th, 2012 AT 6:13 PM
Tiny
KHLOW2008
  • EXPERT
  • 41,967 POSTS

Ignition feed is battery voltage.

Was this
answer
helpful?
Yes
No
Friday, October 12th, 2012 AT 6:53 PM
Tiny
JMMJBN
  • MEMBER

I have 12 v at the pink wire, also to the bcm, I have replaced the switch, also have a drain on battery

Was this
answer
helpful?
Yes
No
Friday, October 12th, 2012 AT 10:29 PM
Tiny
KHLOW2008
  • EXPERT
  • 41,967 POSTS

The drain on the battery should be diagnosed and rectified. It could be related to the BCM logging off. It can be some component not turning off, a bad control module or a relay sticking. The link below should be helpful.

http://www.2carpros.com/articles/car-battery-dead-overnight

Was this
answer
helpful?
Yes
No
Saturday, October 13th, 2012 AT 11:48 AM
Tiny
JMMJBN
  • MEMBER

The drain on bat. Only starts after the bcm goes out, I have checked everything on car and the only thing that checks bad is the bcm.I would like to know the top 10 things that would make the bcm fry in a matter of minutes.

Was this
answer
helpful?
Yes
No
Monday, October 15th, 2012 AT 1:11 PM
Tiny
KHLOW2008
  • EXPERT
  • 41,967 POSTS

A shorting in one of the circuits that is linked to the BCM can cause that. The other would be excessive voltage getting to it.

Was this
answer
helpful?
Yes
No
Monday, October 15th, 2012 AT 3:58 PM
Tiny
JMMJBN
  • MEMBER

The drain on the bat. Is pulsing, I can take out the L/H bat 2 bec fuse from under the hood and it stops, what does that run or what might it be, I thank you for all you help

Was this
answer
helpful?
Yes
No
Monday, October 15th, 2012 AT 10:21 PM
Tiny
JMMJBN
  • MEMBER

I found out itis on the ip/hvac fuse inside car, but dont know what that is and book does not say

Was this
answer
helpful?
Yes
No
Monday, October 15th, 2012 AT 10:55 PM
Tiny
KHLOW2008
  • EXPERT
  • 41,967 POSTS

Diagram shows the power distribution for the L/H bat 2 bec fuse and if the IPC/HVAC BATT fuse that is draining, disconnect the HVAC control assy to test if it is the one causing the problem or the IPC (instrument panel cluster)

Was this
answer
helpful?
Yes
No
Tuesday, October 16th, 2012 AT 9:53 AM
Tiny
JMMJBN
  • MEMBER

What does HVAC stand for and where is it

Was this
answer
helpful?
Yes
No
Tuesday, October 16th, 2012 AT 12:54 PM
Tiny
KHLOW2008
  • EXPERT
  • 41,967 POSTS

Heating, Ventilation, Air Conditioning - that is the control panel for the A/C heater system.

Was this
answer
helpful?
Yes
No
Tuesday, October 16th, 2012 AT 5:50 PM
Tiny
GERGINIST
  • MEMBER

Did you find anything out on your dilemma? I am having kinda the same issues, gauges drop to zero while driving, intermittently. Replaced the ignition switch, checked and verified every fuse while setting still and everything working fine. Scanner says no codes. Only seen it error while driving/moving. Above schematic will help, didn't think of HVAC module thrown into the mix.

Was this
answer
helpful?
Yes
No
Saturday, November 24th, 2012 AT 4:37 PM

Please login or register to post a reply.

Related Body BCM Not Working Content

Recommended guides