2004 Chevrolet Cavalier Ecotec 2.2 Not circulating coolant

Tiny
JHEAD85
  • MEMBER
  • 2004 CHEVROLET CAVALIER
  • 2.2L
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 90,000 MILES
2004 Cavalier Ecotec 2.2 Not circulating coolant.
Replaced radaitor. Tstat. And waterpump. Even took out the thermostat bit nothin. If I take the top radaitor hose off no coolant is coming out. Only when car warms up the coolant starts to boil. New pump new everything. I give up. Even used special tool so not to mess up timing for waterpump. The original pump I took out had nothin wrong with it but replaced it anyways since I had it. Something's not spinning the pump anyone got any advice.
2004 Cavalier Ecotec 2.2
Do you
have the same problem?
Yes
No
Thursday, April 24th, 2014 AT 1:35 PM

5 Replies

Tiny
ASEMASTER6371
  • EXPERT
Good afternoon my name is roy and I will help

I assume that it overheated prior to the replacement of all the parts. From the overheating you may have damaged the head gasket which would explain the issue that you have.

Have the cylinders tested for a leak down to see if the head gasket is good.

Roy
Was this
answer
helpful?
Yes
No
Thursday, April 24th, 2014 AT 2:23 PM
Tiny
JDL
  • EXPERT
Just a thought, if the water pump is chain driven, can you tell if water pump gear is turning, when you crank it?
Was this
answer
helpful?
Yes
No
Thursday, April 24th, 2014 AT 3:36 PM
Tiny
JHEAD85
  • MEMBER
Well that's what ima do in the next day or two.I've read somewhere that there is a shear pin for the shaft that hold it in place and most likely it broke witch is made to so not to mess up timing. So the car is still timed right but the pump is not spinning at all.I know the gasget is shot from this witch ima replace when I find out out how to get this pump to turn. No sence in replacing that until I fix the water problem. Car runs fine just no coolant is circulating. Any input anyone :)
Was this
answer
helpful?
Yes
No
Saturday, April 26th, 2014 AT 3:08 AM
Tiny
JHEAD85
  • MEMBER
Hey Roy thanks.I know the gasket is wore down from this problem. At the moment the gasket is not to bad don't smoke or nothin. But I know a small amount is getting through but having that wouldn't cus the water not to be flowing. All the lines are clean and clear as well as radaitor. Soon as I get a change I'm going to rip front engine cover off and find out if I can see the actual shaft for the water pump is turning itself.I know for sure that's the problem. Something is not turning the pump and I know 100% I replaced the pump correctly and with the special tool for Eco tec engines. It was having the same problem before I replaced pump.I just figured the pump broke and stopped spinning but that's not the case something else is the problem.
Was this
answer
helpful?
Yes
No
Saturday, April 26th, 2014 AT 3:16 AM
Tiny
JDL
  • EXPERT
Hope you got it going your way?
Was this
answer
helpful?
Yes
No
Thursday, June 25th, 2015 AT 7:38 AM

Please login or register to post a reply.

Recommended Guides