My car was chugging and hesitating

Tiny
SATURN1972
  • 2003 SATURN VUE
  • 167,000 MILES

My car was chugging and hesitating. Code reader said misfire # 2 and 3 changed the plugs but still getting misfire P0303 what can I do next? Also just noticed today smoke coming from under the hood top of engine but sure from where

Do you
have the same problem?
Yes
No
Tuesday, January 29th, 2013 AT 5:14 PM

27 Replies

Tiny
SATURNTECH9
  • EXPERT
  • 30,798 POSTS

Which engine do you have?

Was this
answer
helpful?
Yes
No
Tuesday, January 29th, 2013 AT 5:57 PM
Tiny
SATURN1972
  • MEMBER

V6 3 litre

Was this
answer
helpful?
Yes
No
Wednesday, January 30th, 2013 AT 5:21 PM
Tiny
SATURN1972
  • MEMBER

Going to try the coil next and see

Was this
answer
helpful?
Yes
No
Wednesday, January 30th, 2013 AT 6:00 PM
Tiny
SATURNTECH9
  • EXPERT
  • 30,798 POSTS

If your only getting the code P0303 and you can feel the missfire?Then I would do a spark test and see if the spark is a nice blue spark on that plug?

Was this
answer
helpful?
Yes
No
Thursday, January 31st, 2013 AT 3:02 AM
Tiny
SATURN1972
  • MEMBER

Yes the only code is that P0303 the car does not chug.I just notice in the RPMS the missing.
So you don't think it is the coil? Cause we are going to try the coil pack this weekend.

Was this
answer
helpful?
Yes
No
Thursday, January 31st, 2013 AT 6:08 PM
Tiny
SATURNTECH9
  • EXPERT
  • 30,798 POSTS

Does it only miss at idle?

Was this
answer
helpful?
Yes
No
Thursday, January 31st, 2013 AT 6:37 PM
Tiny
SATURN1972
  • MEMBER

Today I went and filled up the car with gas and now the service engine light is off? Doesn't feel like misfire anymore but there still smoke coming from under the hood when I got home from a 70km drive.? Now what? Should we change the coil anyways?

Was this
answer
helpful?
Yes
No
Friday, February 1st, 2013 AT 12:03 AM
Tiny
SATURNTECH9
  • EXPERT
  • 30,798 POSTS

If its running good now I really doubt you have a bad coil. Where's the smoke coming from?

Was this
answer
helpful?
Yes
No
Friday, February 1st, 2013 AT 4:09 AM
Tiny
SATURN1972
  • MEMBER

After driving about 50 mins smoke is coming from under hood near top of engine close to windshield passenger side can't really see cause of the cover on the engine

Was this
answer
helpful?
Yes
No
Friday, February 1st, 2013 AT 2:30 PM
Tiny
SATURN1972
  • MEMBER

Still no service engine light as well. So am I good you think?

Was this
answer
helpful?
Yes
No
Friday, February 1st, 2013 AT 2:31 PM
Tiny
SATURNTECH9
  • EXPERT
  • 30,798 POSTS

Your going to have to see if oil is leaking on the hot exhaust or what's happening?

Was this
answer
helpful?
Yes
No
Friday, February 1st, 2013 AT 3:57 PM
Tiny
SATURN1972
  • MEMBER

Okay on weekend did compression test on cylinders all were 200% except cylinder 3 that had the misfire it was at 60% how long will my car be able to run like this? What should I do?

Was this
answer
helpful?
Yes
No
Sunday, February 3rd, 2013 AT 10:57 PM
Tiny
SATURNTECH9
  • EXPERT
  • 30,798 POSTS

So number 3 cyl only has 60psi compression?

Was this
answer
helpful?
Yes
No
Monday, February 4th, 2013 AT 12:14 AM
Tiny
SATURN1972
  • MEMBER

Yes that is correct what can I do to fix this problem?

Was this
answer
helpful?
Yes
No
Monday, February 4th, 2013 AT 1:48 PM
Tiny
SATURNTECH9
  • EXPERT
  • 30,798 POSTS

Most likely a valve issue you can do a leak down test to make sure but to fix it you will have to pull the head and a have a valve job done.

Was this
answer
helpful?
Yes
No
Tuesday, February 5th, 2013 AT 2:09 AM
Tiny
SATURN1972
  • MEMBER

Do you know how much that would cost?
My service engine did not come back on when put back together.
Do you know how long I can drive the car like this?

Was this
answer
helpful?
Yes
No
Tuesday, February 5th, 2013 AT 6:57 PM
Tiny
SATURNTECH9
  • EXPERT
  • 30,798 POSTS

Are you sure the compression is that low?Also what's your zip code?

Was this
answer
helpful?
Yes
No
Wednesday, February 6th, 2013 AT 1:18 AM
Tiny
SATURN1972
  • MEMBER

Mechanic said 3 cyl compression was at 60% and others were at 200%

still no service light is not on.

I live in Ontario, Canada

Was this
answer
helpful?
Yes
No
Wednesday, February 6th, 2013 AT 7:37 PM
Tiny
SATURNTECH9
  • EXPERT
  • 30,798 POSTS

60 percent or 60psi?

Was this
answer
helpful?
Yes
No
Please consider a donation if we helped you
Wednesday, February 6th, 2013 AT 8:44 PM
Tiny
SATURN1972
  • MEMBER

All the mechanic said was 60 I guess psi. He said was at 60 when he did the test

Was this
answer
helpful?
Yes
No
Thursday, February 7th, 2013 AT 3:42 PM

Please login or register to post a reply.

Related Engine Smoke Questions

Recommended articles