What caused my headlights to stop working?

Tiny
SCPHIL
  • MEMBER
  • 2002 CHEVROLET AVALANCHE
  • 228,600 MILES
The headlights have stopped working on my avalanche. First it was the high beam when the tilt wheel was moved from the upmost position, so I just drove with the low beams for a while. The highs would work when the steering wheel was all the way up so I know it's not the bulbs. Now the lows have stopped too. The auto sensor is working because the markers and dash lights come on properly. One mechanic suggested I replace the whole steering column. Seems a bit of overkill to me. Can you give an idea where to start? Oh btw, the system must be hot because the fog lights are working.
Do you
have the same problem?
Yes
No
Saturday, February 4th, 2012 AT 2:41 AM

4 Replies

Tiny
MHPAUTOS
  • MEMBER
You will have to check the light loom down the column from the switch, I feel that there will be a break in a wire, expecially if this failed after tilting the wheel or column.
Was this
answer
helpful?
Yes
No
+2
Saturday, February 4th, 2012 AT 2:52 AM
Tiny
SCPHIL
  • MEMBER
Where do I find this? Is it insde the column covers or under the dash?
Was this
answer
helpful?
Yes
No
Saturday, February 4th, 2012 AT 3:00 AM
Tiny
MHPAUTOS
  • MEMBER
Pull the trim off the column and check down from the light switch to the loom plug, there should be on near the bottom of the column.
Was this
answer
helpful?
Yes
No
+1
Saturday, February 4th, 2012 AT 3:06 AM
Tiny
SCPHIL
  • MEMBER
Ok thanks I'll check that. Will let you know what I find.
Was this
answer
helpful?
Yes
No
Saturday, February 4th, 2012 AT 3:10 AM

Please login or register to post a reply.

Sponsored links