My engine is running very rough. The Check Engine and Trac Off lights are on.

Tiny
ALLIEOH
  • MEMBER
  • 2001 PONTIAC SUNFIRE
  • 145,000 MILES
My car was shaking pretty bad when I started it, then smoothing out as I drove. The coolant level had also been dropping, although no leak was ever found. I started experiencing some loss of power while accelerating and the check engine and trac off lights came on, so I stopped into an autozone to get the code on the check engine light. I'm not sure of the exact code, but it was a misfire in cylinder 4. I was told to replace the spark plugs and wires (which had just been done a few weeks before) and the ignition coil. I replaced the coil and my car ran okay for about 200 miles (still losing coolant, but the shaking and power loss stopped), and now I'm experiencing the same problems as before. My oil light also came on for a couple minutes. I checked the oil and it seems that the level has slightly increased, the oil apperas thinner than usual, and it smells like there is quite a bit of gas mixed in with it. I have no idea where to even begin figuring out what's wrong. Please help?
Do you
have the same problem?
Yes
No
Thursday, September 8th, 2011 AT 10:37 PM

2 Replies

Tiny
SATURNTECH9
  • EXPERT
Is there smoke coming out the tail pipe if so what color?So the oil doesnt look milky or the coolant doesnt look choclatey?
Was this
answer
helpful?
Yes
No
-1
Thursday, September 8th, 2011 AT 11:46 PM
Tiny
ALLIEOH
  • MEMBER
No smoke coming out of the tail pipe, the exhaust doesn't smell like coolant or anything either. The oil looks fine other than seeming a little bit too thin, and the coolant color is fine. Have also checked the floor on the passenger side, and it hasn't been getting wet.
Was this
answer
helpful?
Yes
No
-1
Wednesday, September 14th, 2011 AT 6:36 PM

Please login or register to post a reply.

Recommended Guides