Idle speed dropping

Tiny
BOSTJANKOROSEC
  • MEMBER
  • 2001 MAZDA MX5
  • 70,000 MILES
Idle speed on my MX5 often falls to 500 rev/min when approaching to a junction (car shakes) and when I stop, it increases again to approx. (Normal) 850 rev/min. It looks that idling regulation is too slow. I cleaned the IAC valve and tested it's operation - it works in and out properlly! Service couldn't do anything with tester - said it doesn't connect to CPM.
What else can be a problem?
Thanks.

Regards, Bob
Do you
have the same problem?
Yes
No
Tuesday, July 19th, 2011 AT 4:57 PM

2 Replies

Tiny
ASEMASTER6371
  • EXPERT
The iac is a start. First, you cannot clean it as inside the shaft is where it sticks even when commanded to raise the idle. Or, the passages to and from the iac may be restricted.

Roy
Was this
answer
helpful?
Yes
No
Tuesday, July 19th, 2011 AT 6:28 PM
Tiny
BOSTJANKOROSEC
  • MEMBER
Thanks fot answer!
After cleaning it with carburator solvent (it wasn't so dirty), I tried it with 12V voltage from the batterie - it opened and closed (like) normally - quick.
I've just come back from driving and notice also this problem when pressing the clucth for gear change when motor in not fully warm - this is always when motor is more or less cold or after 2 or 3 miles. But when fully warm, idle drop is much smaller when pressing the cluch for gear changing or stopping.
Only IAC is around 500 $ in Europe, so I wouldn't like only to try with it first, unless it is the reason for more and more anoing problem.
Best regards, Bob
Was this
answer
helpful?
Yes
No
Tuesday, July 19th, 2011 AT 7:28 PM

Please login or register to post a reply.

Sponsored links