2001 Hyundai XG300 Brain box socket

Tiny
CONQUEROR
  • MEMBER
  • 2001 HYUNDAI XG300
  • 3.0L
  • V6
  • 2WD
  • AUTOMATIC
  • 1,400 MILES
My brain box got faulted and we changed it, but while removing one of the socket that enters into the brain box it got damaged. So this left the wires all pull out from the male socket. Now I have gotten another socket that was able to enter into the female socket from the brain box but it came with different color of wires. Now we don't know how to connect the wires together because the wires are different. The socket is one of the one the edges. This has left the gear not to select, it only moves with a low gear (gear 4 I think). Please come up with an illustration to show me this. Best Regards. Thanks
Do you
have the same problem?
Yes
No
Friday, November 29th, 2013 AT 2:05 AM

32 Replies

Tiny
HMAC300
  • EXPERT
What color are the wires and which "brain box is it? Where is it located. I need only the colors of the wires you need to connect.
Was this
answer
helpful?
Yes
No
Friday, November 29th, 2013 AT 8:57 AM
Tiny
CONQUEROR
  • MEMBER
Many many thanks for your prompt response. Very greatful. The car is Hyundai XG 300. Its has four different sockets entering its Brain box. The fourth one is the one affected. It has 30 wires with different colors of wires. The brain box is located under the dash board behind the radio/ deck compartment. The socket damage while removing one of the socket that enters into the brain box. So this has left the wires all pull out from the male socket. Now I have gotten another socket that was able to enter into the female socket from the brain box but it came with different color of wires (30 wires). Now we don't know how to connect the wires together because the wires are different. The socket is one of the one the edges. This has left the gear not to select, it only moves with a low gear (gear 4 I think). Please come up with an illustration to show me this how to connect the wires. Best Regards. Thanks
Was this
answer
helpful?
Yes
No
Friday, November 29th, 2013 AT 11:59 AM
Tiny
HMAC300
  • EXPERT
Pics are best I can do you'll hve to try to enlarge it. Hope they are the right ones
Was this
answer
helpful?
Yes
No
-1
Friday, November 29th, 2013 AT 12:07 PM
Tiny
CONQUEROR
  • MEMBER
Thanks for this, am really getting relieved. Please is the second picture illustrating the C44-3? How do I know and locate according to numbers as illustrated. That is which pin is number 1, 2, 3, 4,530 on each row. Please can I get the picture for C44-1 too, this is just incase because C44-1 & C44-4 are both at the edges or are you sure its C44-4 affected. Thanks again for your clear illustration. I appreciate. I will be expecting your response. Hi regards
Was this
answer
helpful?
Yes
No
+1
Friday, November 29th, 2013 AT 9:54 PM
Tiny
CONQUEROR
  • MEMBER
Also how do I differentiate btw this:
White colors
-Input Speed
-Output Speed
- Flash (ELC)
- Up shift

Red/Black colors
- 2nd Solenoid
- Down Shift

Lt Blue / Black
- Red Solenoid
- Up solenoid

Or will they show a light on dash board if tested with continuity. Please let me know a better way to get the wire. I think other wires will gotten easily. Thanks
Was this
answer
helpful?
Yes
No
Saturday, November 30th, 2013 AT 3:07 AM
Tiny
HMAC300
  • EXPERT
First thing the plastic blockSHOULD be numbered and the wires are of a different color. From what you are describing this job is something you shouldn't have tackled because you don't understand basic wiring colors. A coupl eof the c444 go to the same place as long as you follow the color chart and numbers you shold have no problem an dodn't try to find where they go. Besides if you are going to try to find where they go you need what is called a breakout box and a lot of time to try to find them which you don't have the box. If you still haven't removed the wires from the first plastic piece then all you need do is transfer them if you have disconnected them then good luck as I can't send complete harness pics as they would be to small as I can't reduce them enough.
Was this
answer
helpful?
Yes
No
Saturday, November 30th, 2013 AT 5:42 AM
Tiny
CONQUEROR
  • MEMBER
Thanks. Now I understand. Since the same color goes to same place. I will get back to you as soon as am done. Thank you.
Was this
answer
helpful?
Yes
No
Saturday, November 30th, 2013 AT 5:54 AM
Tiny
HMAC300
  • EXPERT
The c44 wires only the other colored ones go to different places. Make sure to do them one at a time if you still have the original plastic if you don't you WILL need a break out box to find them if they are same color.
Was this
answer
helpful?
Yes
No
Saturday, November 30th, 2013 AT 6:15 AM
Tiny
CONQUEROR
  • MEMBER
Thanks. Its just the C44-4 that is affected. Thanks for the caution
Was this
answer
helpful?
Yes
No
Saturday, November 30th, 2013 AT 8:43 AM
Tiny
CONQUEROR
  • MEMBER
Am very greatful. There's clear improvement. Now its can now show the particular gear it is on dash board. I hope u know that one can select the gear manually and it display the particular gear concurrently. Now it is showing 3 even while no moving instead of 1 while on D(drive). What do I do now?Regards
Was this
answer
helpful?
Yes
No
Monday, December 2nd, 2013 AT 9:14 AM
Tiny
HMAC300
  • EXPERT
The only thing I can tell you is to recheck your work and make sure all the connections are good and if you can scan this see if anything shows up. Alos ecm's are vin specific so it may have to be flashed to your car as from the way it sounds yours came from another vehicle. Plus you never said how the original was damaged so it may have damged the tcm in the process or your sport mode switch.
Was this
answer
helpful?
Yes
No
Monday, December 2nd, 2013 AT 9:34 AM
Tiny
CONQUEROR
  • MEMBER
Okay. I will do the scanning error so as to clear and get back to you. Thanks
Was this
answer
helpful?
Yes
No
Monday, December 2nd, 2013 AT 12:52 PM
Tiny
HMAC300
  • EXPERT
That ecm has to be programmed to your car I dont' think you understand that. There is nothing more I can offer you for a fix.
Was this
answer
helpful?
Yes
No
Monday, December 2nd, 2013 AT 12:54 PM
Tiny
CONQUEROR
  • MEMBER
Okay sir. I will work on how it will be programmed and get back to you. Am really gaining form you. Thanks
Was this
answer
helpful?
Yes
No
Monday, December 2nd, 2013 AT 1:44 PM
Tiny
HMAC300
  • EXPERT
A pro mechanic has to program it
Was this
answer
helpful?
Yes
No
Monday, December 2nd, 2013 AT 3:14 PM
Tiny
CONQUEROR
  • MEMBER
It has now been programmed. Now the gear select its self but if there's a cause of matching or pressing the break before its selects to gear 5, it comes and stay at gear 3 even if the car is stopped totally (as in traffic). If the ignition is turn off and on again it will start counting again from gear 1 or 2 and then repeat the same process above.. Note that if the car is turn off and turn on again it select normally and at times 'jump' to gear 4 from 3. It's not showing any trouble code again. Any possible cause sir? Thanks for you attention. Hi regards
Was this
answer
helpful?
Yes
No
Wednesday, December 4th, 2013 AT 6:03 AM
Tiny
CONQUEROR
  • MEMBER
It has now been programmed. Now the gear select its self but if there's a cause of matching or pressing the break before its selects to gear 5, it comes and stay at gear 3 even if the car is stopped totally (as in traffic). If the ignition is turn off and on again it will start counting again from gear 1 or 2 and then repeat the same process above.. Note that if the car is turn off and turn on again it select normally and at times 'jump' to gear 4 from 3. It's not showing any trouble code again. Any possible cause sir? Thanks for your attention. Hi regards
Was this
answer
helpful?
Yes
No
Wednesday, December 4th, 2013 AT 6:08 AM
Tiny
HMAC300
  • EXPERT
I have no idea best thing is to have a mechanic look at this and make sure you tell him what you have done. Then he can recheck tings over once again for loose connections as this is n't the original question which I answered the best I could. Some of this stuff has to be physically looked at like I've stated before, especially the way your car was and it may be a switch or harness problem due to the original problem. I have no further suggestions.
Was this
answer
helpful?
Yes
No
Wednesday, December 4th, 2013 AT 6:57 AM
Tiny
CONQUEROR
  • MEMBER
Thank you. I really appreciate you. I will get to you for any positive development.
Was this
answer
helpful?
Yes
No
Wednesday, December 4th, 2013 AT 7:20 AM
Tiny
CONQUEROR
  • MEMBER
Its now working fine. Its the input and output wire that was wrongly fixed to each other. Thank you so much for your help so far. You are truly a car pro and problem solver. I hope to feel more of you.
Was this
answer
helpful?
Yes
No
Monday, December 9th, 2013 AT 10:11 AM

Please login or register to post a reply.

Recommended Guides