Is my fuel filter clogged or is it maybe a speed sensor

Tiny
RIBICH
  • MEMBER
  • 2001 HYUNDAI ELANTRA
  • 105,000 MILES
The past few weeks the car hiccupped occassionaly when driving at highway speed (55-60mph)but kept going good. I've put new plugs in, tranny and oil good, air filter good, however, after 5 miles (30-35 mph)(slight grade) it almost stalled (no reaction from gas pedal). After another 5 miles on another grade, it stalled out. I waited a couple minutes and restarted. 10 miles later at highway speed (55-60 mph) it bogged down and came to a stall (no grade, level road). I restarted again and made it another 3 miles to work. Is this the fuel filter or electronic/computer gizmos? I don't feel like tearing out the back seat if it is not the filter/pump.
Do you
have the same problem?
Yes
No
Monday, October 17th, 2011 AT 5:53 PM

3 Replies

Tiny
FIXITMR
  • MEMBER
When you say hiccup do you mean cuts out completely for a second? Not bogs/slows down?
Was this
answer
helpful?
Yes
No
Monday, October 17th, 2011 AT 6:15 PM
Tiny
RIBICH
  • MEMBER
The hiccup was just a fraction of a second little jolt, a very slight hestation, but kept on rolling.
Was this
answer
helpful?
Yes
No
Monday, October 17th, 2011 AT 6:28 PM
Tiny
FIXITMR
  • MEMBER
Does sorta sound like a fuel problem though. A fuel pressure test could confirm this. And engine sensors also have great influence on fuel delivery even if pressure is right constantly.
Was this
answer
helpful?
Yes
No
Monday, October 17th, 2011 AT 6:32 PM

Please login or register to post a reply.

Recommended Guides