2001 GMC Sonoma fuel pump

Tiny
NGLENN
  • MEMBER
  • 2001 GMC SONOMA
  • 4.3L
  • V6
  • 4WD
  • AUTOMATIC
  • 120,000 MILES
This is in answer to our question from 5 days ago. Thank you for that. Now, the latest. We checked & have 12v at the pump for 2 seconds. What would be the next step? My earlier question from today was written before I checked this recent answer from you. Sorry about that
Do you
have the same problem?
Yes
No
Thursday, December 5th, 2013 AT 11:41 AM

5 Replies

Tiny
SATURNTECH9
  • EXPERT
The next thing I would check is see if you have 2 ohms or less to your ground to the fuel pump?If so the fuel pump should be running?
Was this
answer
helpful?
Yes
No
Thursday, December 5th, 2013 AT 11:56 AM
Tiny
NGLENN
  • MEMBER
Thank you for your help. I have 1.9 ohms from ground to the fuel pump body. Does that tell me bad pump?
Was this
answer
helpful?
Yes
No
Friday, December 6th, 2013 AT 9:08 AM
Tiny
NGLENN
  • MEMBER
Thank you for your answer yesterday. I have 1.9 ohms from ground to the fuel pump. Does that tell me bad pump?( 2001 Sonoma question)
Was this
answer
helpful?
Yes
No
Friday, December 6th, 2013 AT 9:14 AM
Tiny
SATURNTECH9
  • EXPERT
If your sure you have power and ground to the fuel pump and its not running then you have a bad fuel pump. You can try adding a ground to the fuel pump just to be sure. Try this also while cranking the engine to start it. Try smacking the fuel tank right where the fuel pump is. See if the fuel pump starts running or it starts.
Was this
answer
helpful?
Yes
No
Friday, December 6th, 2013 AT 10:53 AM
Tiny
NGLENN
  • MEMBER
Thank you. One last question.. Just to make sure, the steady voltage to the pump is 5.05vdc & the 12 v was the 2 seconds test I did . Is that 5v normal?
Was this
answer
helpful?
Yes
No
Friday, December 6th, 2013 AT 12:20 PM

Please login or register to post a reply.

Sponsored links