2000 Kia Spectra Camshaft Sprocket to Camshaft Orientation

Tiny
FASTEDDY530
  • MEMBER
  • 2000 KIA SPECTRA
  • 1.8L
  • 4 CYL
  • FWD
  • MANUAL
  • 165,000 MILES
Can someone tell me the correct installation of the two camshaft sprockets, when I picked up the cylinder head from the machine shop they had been removed. It seems they can be installed 180 degrees out of synch with the camshaft. Thanks in advance!
Do you
have the same problem?
Yes
No
Monday, December 8th, 2014 AT 8:06 PM

11 Replies

Tiny
MHPAUTOS
  • EXPERT
Sprockets are marked I for inlet and E for exhaust, timing marks are at 12.00 O'Clock for both see pic
Was this
answer
helpful?
Yes
No
Tuesday, December 9th, 2014 AT 12:15 AM
Tiny
FASTEDDY530
  • MEMBER
Thank you for your help!
Was this
answer
helpful?
Yes
No
Wednesday, December 10th, 2014 AT 9:04 PM
Tiny
MHPAUTOS
  • EXPERT
My pleasure, thank you for using 2carpros.
Was this
answer
helpful?
Yes
No
Thursday, December 11th, 2014 AT 12:42 AM
Tiny
FASTEDDY530
  • MEMBER
I'm new to working on Kia's so I wonder if I may tap into your knowledge once again. After replacing the broken cam belt and installing the repaired cylinder head, the car fired up but ran a little rough and would stall if I came back to idle. I also noticed a squeel noise if I revved the engine just before it was going to stall. I hooked up a battery charger as the battery had a hard time cranking the engine initially. The "Check Engine Light" came on and I scanned a code P1505 Idle Speed Control Actuator-low voltage. I'm going to first check the P/S and Alternator belts to eliminate them as the source of the squeel noise. Any ideas?
Was this
answer
helpful?
Yes
No
Thursday, December 11th, 2014 AT 8:53 PM
Tiny
MHPAUTOS
  • EXPERT
I would make sure that the battery is ok, check the charge rate, belts are tight and the iac plug is clean and a tight fit in the socket.
Was this
answer
helpful?
Yes
No
Friday, December 12th, 2014 AT 12:51 AM
Tiny
FASTEDDY530
  • MEMBER
Thank you so much for your quick response, I will check all the items you mentioned today. Thanks again!
Was this
answer
helpful?
Yes
No
Friday, December 12th, 2014 AT 8:47 AM
Tiny
MHPAUTOS
  • EXPERT
Ok, good luck
Was this
answer
helpful?
Yes
No
Friday, December 12th, 2014 AT 2:20 PM
Tiny
FASTEDDY530
  • MEMBER
Test drove the vehicle today and it runs great and pulls hard but still stalls at idle. Pulled codes P1505 "IdleAir Control Valve-Low voltage" and a P1507 "Idle Air Control Valve Closing Voltage Low". So I probed the voltage feed at the connector to the IAC and am getting 5 volts. Without a Kia manual or specs I don't know if that's low or normal for the Kia. I also removed the IAC and cleaned it, also fed battery voltage to the center terminal of the IAC and grounded each outside terminal in turn and it seemed to react and function. I find all this very interesting but I would sure like to fix the idle speed on this car, any ideas?
Was this
answer
helpful?
Yes
No
Saturday, December 13th, 2014 AT 9:04 PM
Tiny
MHPAUTOS
  • EXPERT
Pin 29 Green/White at the ECU is the supply for the IAC there is no mention of voltages that I can see so I would be expecting 12V
Was this
answer
helpful?
Yes
No
Sunday, December 14th, 2014 AT 1:06 AM
Tiny
FASTEDDY530
  • MEMBER
Great, thank you so much for your help, have a great week!
Was this
answer
helpful?
Yes
No
Sunday, December 14th, 2014 AT 9:17 PM
Tiny
MHPAUTOS
  • EXPERT
Ok, good luck, thank you for using 2carpros
Was this
answer
helpful?
Yes
No
Monday, December 15th, 2014 AT 1:35 AM

Please login or register to post a reply.

Recommended Guides