I HAVE A PROBLEM WITH THE HEATER IN FRONT NOT ...

2000 Honda Odyssey

Tiny

Jvakmc94

December, 29, 2012 AT 7:03 PM

I have a problem with the heater in front not blowing hot air. The rear works good but the front is Luke warm. I have checked the blend door and the motor, both seem to be working good, I've bled what I think is all the air out of the system when I flushed the radiator. If this helps, when I looked underneath where the blend door is, when the temp is turned up all the way the arm is not going all the way to the end of the track for the blend door. It looks like it is leaving it open just a little. Could this be the motor that controls opening and closing the door or the climate control panel?

FOUND 4982 RELATED QUESTIONS

No Heat

37 ANSWERS
5 IMAGES

3 Answers

Tiny

saturntech9

December, 29, 2012 AT 7:16 PM

Have you checked to see if both the heater hoses going to the heater core at the firewall are getting too hot to hold?

Tiny

Jvakmc94

January, 21, 2013 AT 2:29 AM

Sorry for not getting back sooner, but no. The hoses are warm but not too hot to touch. Both the front and rear are blowing warm but not hot. Could the heater core be so clogged that I need to flush it itself?

Tiny

saturntech9

January, 21, 2013 AT 6:43 AM

Could be but usually when the heater core is clogged one hose will be too hot to hold while the other hose is cool to warm.

Please login or register to post a reply.

Blend Door Actuator Replacement
Cabin Air Filter Replacement Porsche 911
Cabin Air Filter Replacement
Cabin Air Filter Replacement Saturn Vue