P0300 Misfire & loss of power

Tiny
MUSICMANDON
  • 2000 GMC JIMMY
  • 128,000 MILES

I have a 2000 Jimmy 128k. I loose power & get a miss fire code under load. When I tow up a hill start feeling loss off power. Almost dies. Also happens cold when going up a hill. Changed the obvious (plugs, cap, rotor, also cam & crank sensors) and use only Delco parts

Do you
have the same problem?
Yes
No
Monday, October 1st, 2012 AT 5:58 PM

5 Replies

Tiny
KHLOW2008
  • EXPERT
  • 41,940 POSTS

Have the fuel pressure checked. You could have a clogged fuel filter affecting the fuel supply resulting in loss of performance.

If the Malfunction Indicator Light is shoiwng, get a scan to cehck for trouble codes.

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
Monday, October 1st, 2012 AT 6:20 PM
Tiny
MUSICMANDON
  • MEMBER

Checked fuel line, it had some fluxuations. Changed to a Delco fuel filter. First day out up inclune in road (first 10 mins) idoit light on Misfire

Was this
answer
helpful?
Yes
No
Monday, October 8th, 2012 AT 5:34 PM
Tiny
KHLOW2008
  • EXPERT
  • 41,940 POSTS

What is the trouble code?

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
Monday, October 8th, 2012 AT 5:41 PM
Tiny
MUSICMANDON
  • MEMBER

P300 random misfire (90%) cyc 4 10% but I think that was by chance

Was this
answer
helpful?
Yes
No
Monday, October 8th, 2012 AT 6:03 PM
Tiny
KHLOW2008
  • EXPERT
  • 41,940 POSTS

Basics have been covered so you need to go further into diagnostics.
Have you checked the fuel pressure and air filter?
Try cleaning the MAF.

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
Monday, October 8th, 2012 AT 6:10 PM

Please login or register to post a reply.

Related Engine Low Power Questions

Help us by donating