2000 Ford Ranger engine stalling

Tiny
WHEELCHAIRDUDE49
  • MEMBER
  • 2000 FORD RANGER
  • 64,000 MILES
No leaks in the air tube. Code P1121 changed the tps, no change took it for a test ride
and it ran terrible, loss of power, now it wont turn over.
Now I am at a loss of what to do? And other ideas?
Thanks
Do you
have the same problem?
Yes
No
Sunday, June 30th, 2013 AT 2:54 PM

37 Replies

Tiny
SATURNTECH9
  • EXPERT
Which engine do you have?
Was this
answer
helpful?
Yes
No
Sunday, June 30th, 2013 AT 3:49 PM
Tiny
WHEELCHAIRDUDE49
  • MEMBER
2.5
Was this
answer
helpful?
Yes
No
Sunday, June 30th, 2013 AT 3:55 PM
Tiny
SATURNTECH9
  • EXPERT
I see that code says intake air temperature sensor intermittent nothing to do with the throttle position sensor. Do you have a scan tool that can read live data like intake air temp sensor?
Was this
answer
helpful?
Yes
No
Sunday, June 30th, 2013 AT 6:07 PM
Tiny
SATURNTECH9
  • EXPERT
I am sorry looked up the wrong code looked up code P1115 by mistake. Do you have a scan tool you can read the throttle position sensor on and mass air flow sensor on?Since that code is for tps inconsistent with Maf sensor.
Was this
answer
helpful?
Yes
No
Sunday, June 30th, 2013 AT 6:10 PM
Tiny
SATURNTECH9
  • EXPERT
Also have you tried cleaning the mass air flow sensor with mass air flow sensor cleaner to see if it runs any different?
Was this
answer
helpful?
Yes
No
Sunday, June 30th, 2013 AT 6:15 PM
Tiny
WHEELCHAIRDUDE49
  • MEMBER
Yes I do have a code reader. Just put a new 80.00 maf sensor on it in June. Put new tps on it today.
I'm just wondering if the maf sensor went bad already. The starter wont turn over on it now si I cant start it and
read the live data
Thanks
Was this
answer
helpful?
Yes
No
Sunday, June 30th, 2013 AT 6:43 PM
Tiny
SATURNTECH9
  • EXPERT
So the starter is inop you have a no crank no start?Does the starter make any noise when trying to start it?Also you can watch the tps reading with the key in the run position while moving the gas pedal and watching your scan tool.
Was this
answer
helpful?
Yes
No
Monday, July 1st, 2013 AT 6:57 AM
Tiny
WHEELCHAIRDUDE49
  • MEMBER
Correct. No noise at all. Friend is going to remove starter tonight. Is it possible that the maf sensor failed after 3 weeks?
Bought it from rock auto
Was this
answer
helpful?
Yes
No
Monday, July 1st, 2013 AT 7:02 AM
Tiny
SATURNTECH9
  • EXPERT
Anything is possible do you have a k and n air filter ontthat? Before you remove the starter see if you have power to the small trigger wire on the starter with the key in the start position?
Was this
answer
helpful?
Yes
No
Monday, July 1st, 2013 AT 12:04 PM
Tiny
WHEELCHAIRDUDE49
  • MEMBER
I just have a stock filter. Ok ill have him do it
Was this
answer
helpful?
Yes
No
Monday, July 1st, 2013 AT 12:24 PM
Tiny
SATURNTECH9
  • EXPERT
Alright keep me posted.
Was this
answer
helpful?
Yes
No
Monday, July 1st, 2013 AT 6:46 PM
Tiny
WHEELCHAIRDUDE49
  • MEMBER
Changed the o2 sensor and got rid of the code. Engine has lack of power and stalls when cold. When it warms up
it runs fine. No codes
Was this
answer
helpful?
Yes
No
Sunday, July 7th, 2013 AT 11:31 AM
Tiny
SATURNTECH9
  • EXPERT
So you have the lack of power all the time?And it only stalls when cold?
Was this
answer
helpful?
Yes
No
Sunday, July 7th, 2013 AT 1:43 PM
Tiny
WHEELCHAIRDUDE49
  • MEMBER
No, just when it's cold. Then it seems as soon as the engine warms up runs perfect.
Was this
answer
helpful?
Yes
No
Sunday, July 7th, 2013 AT 3:21 PM
Tiny
SATURNTECH9
  • EXPERT
Have you checked the coolant temp sensor yet?
Was this
answer
helpful?
Yes
No
Sunday, July 7th, 2013 AT 7:40 PM
Tiny
WHEELCHAIRDUDE49
  • MEMBER
No I havent
Was this
answer
helpful?
Yes
No
Sunday, July 7th, 2013 AT 8:09 PM
Tiny
SATURNTECH9
  • EXPERT
If the lack of power and stalling only happen when cold I would check the coolant temp sensor.
Was this
answer
helpful?
Yes
No
Sunday, July 7th, 2013 AT 8:46 PM
Tiny
WHEELCHAIRDUDE49
  • MEMBER
Just changed the ect sensor yesterday. The truck still stalls at lights and stop
signs. Still have some loss of power at take off.
Was this
answer
helpful?
Yes
No
Monday, July 15th, 2013 AT 12:10 PM
Tiny
SATURNTECH9
  • EXPERT
Did it get any better with the new coolant temp sensor?
Was this
answer
helpful?
Yes
No
Monday, July 15th, 2013 AT 8:42 PM
Tiny
WHEELCHAIRDUDE49
  • MEMBER
No it actually got worse. I think its the wrong sensor, so i'm going to put the old one back on. The end of it didn't look like the one I took out.
Was this
answer
helpful?
Yes
No
Monday, July 15th, 2013 AT 9:07 PM

Please login or register to post a reply.

Recommended Guides