Why is my 2000 STS Seville not starting?

Tiny
KEYLO22
  • MEMBER
  • 2000 CADILLAC STS
  • 176,054 MILES
Yesterday I drove my car probably around 34 to 40 miles then stopped at a store was gone for maybe 30 mins came back out it wouldn't start up. I had someone try to jump the battery and it didn't help so we took battery to a advance auto they gave me a print out of the diagnostic saying it was a bad battary so I replaced it with a new one. Tried to start it up again and it didn't start up. I heard a clicking noise when I turn the ignition and the lights come on, radio, ac/heater, seats heat up everything except the ignition won't start up the car. Help!
Do you
have the same problem?
Yes
No
Tuesday, September 27th, 2011 AT 1:30 AM

4 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
IF you hear a clicking, chances are either there is a bad connection at the starter, weak ground, or the starter is bad.
Was this
answer
helpful?
Yes
No
+1
Tuesday, September 27th, 2011 AT 1:50 AM
Tiny
KEYLO22
  • MEMBER
Jacobandnicolas another question could it also have something to do with the relay switch.
Was this
answer
helpful?
Yes
No
Tuesday, September 27th, 2011 AT 2:21 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
It could be the starter relay, but usually you don't get a clicking from the starter.
Was this
answer
helpful?
Yes
No
Tuesday, September 27th, 2011 AT 2:47 AM
Tiny
CADIEMAN
  • MEMBER
Check the battery connections for a build up of corrosion. Check the voltage at the starter. If its one click try and tap on the starter to see if it starts. If it clicks multible times it a connect problem like jacobandnickolas said. Ty for using 2carpros
Was this
answer
helpful?
Yes
No
Tuesday, September 27th, 2011 AT 4:09 PM

Please login or register to post a reply.

Recommended Guides