WHEN I START THE ENGINE AND ALLOW IT TO RUN FOR ...

1999 Toyota Camry

Tiny

dapo falope

December, 5, 2012 AT 4:07 PM

When I start the engine and allow it to run for 10 to 15minutes it works but when I decice to move out quickly and did not allow it to run for 10minutes, the engine goes off when the gear is engaged, but when I allow it to rest for another15mins and I crank it, its starts again.

FOUND 3059 RELATED QUESTIONS

7 Answers

Tiny

KHLow2008

December, 5, 2012 AT 4:23 PM

Do you mean it does not crank after it stalls or it cranks but would not restart?
After restarting, do you have to wait for it to warm up?
What is the idling rpm when it is first started?
Is the Malfunction Indicator Light showing?

Tiny

dapo falope

December, 5, 2012 AT 5:02 PM

Yes it does not ccrank after it stalls, the idle rpm is 1000rpm, after leaving it for more than 15minutes and I crank again it then picks up. Until the next day it starts alloveragain

Tiny

KHLow2008

December, 5, 2012 AT 5:21 PM

Check the ignition switch.

http://www.2carpros.com/articles/car-engine-will-not-crank-over

Above link explains what to look for when you are not able to crank.

Tiny

dapo falope

December, 5, 2012 AT 5:38 PM

Ok, is it the one located on the rigth handside when I open the bunnet?

Tiny

dapo falope

December, 5, 2012 AT 5:39 PM

It has a purple color

Tiny

KHLow2008

December, 5, 2012 AT 5:44 PM

Ignition switch is the one at end of ignition key.

http://www.2carpros.com/articles/how-an-ignition-switch-works

Tiny

dapo falope

December, 5, 2012 AT 6:40 PM

Thanks will look for an expert to fix it.

Please login or register to post a reply.

Transmission Service Ford Super Duty F-250
Transmission Service Toyota Tacoma
Transmission Fluid Replacement Mercedes Benz
Automatic Transmission Service
Transmission Drain and Refill Kia Sportage
Pulling an Auto Trans? Easy Instructions
Transmission Turbine Sensor Replacement