• Tiny
  • jennac33
  • 1999 Jeep Grand Cherokee
  • V8
  • AWD
  • automatic
  • 212,000 miles

I have a 1999 Jeep Grand Cherokee in good condition (considering the mileage). Last week when I stopped for lunch, I came out and tried to start it and it wouldn't even respond at all when I turned the key (radio/power wouldn't turn on on the first click, and it wouldn't turn over). The car had power though, because the inside lights worked and it beeped when the driver door was open etc. I had it towed and the mechanic said he used to have a Jeep and remembered this happened to him once and it was just the fuze that had been tripped. So he replaced it, but he said if it keeps happening it could be a bigger problem. One week later, it happened again yesterday. This time I replaced the fuze myself and tried starting it and when I turned the key half way, the gauges lit up and I had radio and power, then when I tried to turn it over all the way, the fuze went again. Any thoughts? The mechanic said that it could be the ignition. I'm just trying ot get an idea of what it is so I know whether to abandon the car or get it fixed.

Do you
have the same problem?
Wednesday, February 23rd, 2011 AT 7:39 PM

1 Reply

  • Tiny
  • jcninja636
  • Member

Check the wiring harness located in the right (should be the right side) just over the strut tower.
Large harness could be rubbing on the top bolt of the strut/suspension and causing short.
Let me know if that's not it and I can add more checks, but I would be that's it.

Was this
Thursday, February 24th, 2011 AT 3:56 AM

Please login or register to post a reply.

Similar Questions