1999 Ford E-Series Van runs horriable

Tiny
ANDREW RIVERA
  • MEMBER
  • 1999 FORD E-SERIES VAN
  • 256,000 MILES
Gotta 7.3 turbo diesel 99 ford econoline that runs horriable it runs like a gasoline engine that doesnt have spark in one cylinder has no power at all wont even take off sometimes wont turn on gotta let it sit for a long time then it will turn on fine then doesnt the same thing all over plz help this is my work van thank you
Do you
have the same problem?
Yes
No
Wednesday, October 23rd, 2013 AT 1:47 PM

6 Replies

Tiny
MADMIKE1735
  • EXPERT
As far as the "feels like a gas engine misfire" this is mostlikely a bad injector. What worries me, is you describe no power. These have from time to time been known for turbos going. Do you have oil comming out of your exaust? How does this engine start? Long cranking? The glowplugs fire this engine for start up, then compression fires the cylinders from there. There are a numerous amount of causes for what you describe. Injectors, and low compression most common for the misfire you feel, and turbo being common for low power.
Was this
answer
helpful?
Yes
No
Friday, October 25th, 2013 AT 5:36 PM
Tiny
ANDREW RIVERA
  • MEMBER
Well I changed the glow plugs all 8 of them and the diesel fuel filter they were both bad I guess because now she starts up much much better now its within like 2 or 3 seconds of cranking she fires up before it was a serious hassle to get her to fire up but I still get the same loosing of power I run her for about 30 min to an hour all the sudden she looses power I park shut it off leave it there for like 45 min fire it back up boom she runs perfect so I got the exsesive crankin problem taken care of now im just loosing power during a regular drive
Was this
answer
helpful?
Yes
No
Wednesday, November 13th, 2013 AT 9:33 AM
Tiny
MADMIKE1735
  • EXPERT
There is an injector driver, located above the intake manifold, towards front of engine, on driver side. Has an electrical plug on top. This may be intermittantly failing. It controls oil flow to your injectors. Very common part to go bad, and will also give symptoms you describe. It is a bit tricky to change, as it is 3 pieces. And in a bad place. Take your time, and dont get mad at it. Should take about 45min to an hr first time around.
Was this
answer
helpful?
Yes
No
Thursday, November 14th, 2013 AT 4:56 PM
Tiny
ANDREW RIVERA
  • MEMBER
I tried replacing the glow plugs all it gave me was a better start sometimes I still have too use starting fluid truck I havent kept you guys updates but yeah the truck runs horriable but I shut it off let it cool down then fire it back up then runs normal till 15 min after it starts acting up again I have a video I can email you guys so you can see
Was this
answer
helpful?
Yes
No
Thursday, January 9th, 2014 AT 8:42 AM
Tiny
ANDREW RIVERA
  • MEMBER
http://www.youtube.com/watch?v=1NvRPRFdZC0 this link shows you another person that's also having the same exacly problem I have my truck does the same exact thing
Was this
answer
helpful?
Yes
No
Thursday, January 9th, 2014 AT 10:03 AM
Tiny
ANDREW RIVERA
  • MEMBER
http://www.youtube.com/watch?v=OcDOoePi_Bg another video that shows kinda how my truck runs same smokeing and sound jus no oil all over the place and if I keep punching it it eventually just stalls on me
Was this
answer
helpful?
Yes
No
Thursday, January 9th, 2014 AT 10:05 AM

Please login or register to post a reply.

Recommended Guides