1999 Chevy Tahoe #4 cylinder misfire, etc

Tiny
JCAT66
  • MEMBER
  • 1999 CHEVROLET TAHOE
Engine Performance problem
1999 Chevy Tahoe V8 Four Wheel Drive Automatic

Hi guys, I've been reading your forum. Y9ou guys seem to have a grip on what cylinder 4 misfire so I will present my questions and be happy to donate accordingly. I'm in dire need of resolving this issue as this is my only vehicle, and I'm a single father with two kids.
OK HERE GOES.

Yesterday, was takin the kids out to lunch. I was stopped at a red light entering the highway on ramp, light turned green, got on the on ramp started to accelerate, all was good, till about two miles on the highway, couldn't seem to accelerate past 55 - 60 MPH just had no power, check engine light came on and started flashing, so I pulled over, truck started idling bad. Managed to g3et off the next exit made a U- turn and came home. In writing this question to you it may help your answer, in consideration knowing that I am very mechanically inclined not only with the 350 motor in my truck but with custom Harley builds. After getting home my buddies father came over who is a mobile mechanic, and he put his computer on it, came up with a # 4 cylinder misfire, so we started to diagnose the simplest things, I.E put a new spark plug in, lplug wires, checked the cap even put a new one on. Still got the same code. Logically to me, the next thing tio check would be the injector. So I went and spent $61 on a new injector from Advanced Auto. 8:00 Last night myself, my buddy, and my son, start do dig in to replace the injector on #4, which is obviously the second cylinder from the front on the right side. After realizing we couldn't g3et the manifold off without removing the thermostat housing, we did so, and some coolant leaked under the manifold. Finally we removed the manifold vacuumed out all the ports with a shop vac, and cleaned it with carb cleaner to remove all carbon deposits, installed new injector, put it all back together started the truck and it smoked like crazy for a while, ( probably because of the coolant that dripped into the block from removing the thermostat housing while the manifold was loose.) Now it seems I have a lot of condensation coming out of my exhaust at the tailpipe, but the smoke is cleared, and It's running exactly as it was before we put the injector in. Idling rough, RPM's are going up and down, stalls when you put it in gear, basically runs like crap. I'm fresh out of ideas, this truck is babied, and just had a $500 tune up 4,000 miles ago. Any help would be really cool. Thank You Joe in 95 degree Orlando, Fl weather.

something to add to this post.
i have put in a new coil, wires cap and button as well. My thoughts, maybe stuck open valve, or valve guide. Im running out of ideas, really got me bugged, also added some seafoam to oil and gas, ran the truck up and down the highway, with no results. HELP!

Do you
have the same problem?
Yes
No
Sunday, June 13th, 2010 AT 11:48 AM

4 Replies

Tiny
DOCFIXIT
  • EXPERT
Hi
Was code P0304? Still have light on? Was compression checked? Possibility of vacuum leak at intake gasket
Let me know
Thanks for donate
Was this
answer
helpful?
Yes
No
Monday, June 14th, 2010 AT 10:14 AM
Tiny
JCAT66
  • MEMBER
Tested compression cylinder was dead, must be stuck valve? I dont think pushrod as its not tapping or makin any strange noises, any ideas how to free it up without takin of heads.I put a mixture of brake fluid and motor oil in, about a quater cup or 2 oz, held my finger over the hole and started it, then tested comp after a min, and was same, dead. Any ideas. And no prob on the donation. And yes p0304 was code, but that dont matter now, we know theres no compression right.
Was this
answer
helpful?
Yes
No
Monday, June 14th, 2010 AT 2:25 PM
Tiny
DOCFIXIT
  • EXPERT
Cylinder leak down would tell in intake or exhaust. With running go to tailpipe hold a rag at end of pipe if it sucks into pipe and blows back out then exhaust valve burnt
Was this
answer
helpful?
Yes
No
Monday, June 14th, 2010 AT 2:36 PM
Tiny
JCAT66
  • MEMBER
Ok just did that and its running strong wont even let me stuff a rag in it, just blowin, no suckin. At all

think it may be related to my x-wife. Lol
Was this
answer
helpful?
Yes
No
-1
Monday, June 14th, 2010 AT 2:40 PM

Please login or register to post a reply.

Recommended Guides