1999 Malibu LS stalled running at full speed

Tiny
PAMMYCA
  • MEMBER
  • 1999 CHEVROLET MALIBU
  • 50,500 MILES
1999 Malibu LS shut off while running full speed several times in one day. Put in dry gas - thought maybe bad gas. 2 days later it stalls out and all heck broke loose with vibration and engine noise. Towed to garage and guy lifts hood and says broken. Guy at garage it was towed to lifted the hood and said looking in oil well thought it was a cracked cam shaft - $2,000 to repair. After a bunch of inquiries, I'm led to believe it could be a number of things. It's a 3.1 litre engine, 60 degree, V6 and said 3 cylinders are hitting. I need advice!
Do you
have the same problem?
Yes
No
Sunday, March 18th, 2012 AT 1:36 AM

3 Replies

Tiny
RASMATAZ
  • CERTIFIED MECHANIC
What is it doing now? Cranks over and will not start or just won't crank at all/nothing when key is turn to cranking position-let me know
Was this
answer
helpful?
Yes
No
Sunday, March 18th, 2012 AT 1:44 AM
Tiny
PAMMYCA
  • MEMBER
Mechanic says 3 of 6 cylinders running but without dual overhead cam, what can it be? Personally I don't think the mechanic knows if he can say broken cam shaft without taking anything apart.
Was this
answer
helpful?
Yes
No
Sunday, March 18th, 2012 AT 2:01 AM
Tiny
RASMATAZ
  • CERTIFIED MECHANIC
Answer the question I've asked you above, this will give me a direction how to advise you what's going on.I don't eat fish and I can smell it-your cast
Was this
answer
helpful?
Yes
No
Sunday, March 18th, 2012 AT 3:12 AM

Please login or register to post a reply.

Sponsored links