I RECENTLHY DID A FUEL INJECTION SERVICE ...

1998 Nissan 200SX

Tiny

jonp069

March, 24, 2013 AT 5:28 PM

I recentlhy did a fuel injection service cleaning, through the intake plenum and in the gas tank. When I start the car when the motor is cold it idles fine but when I start to drive it acts like not gitting enough fuel. After a couple min it doesnt do it any more then when its wormed up and I come to a light I push in the clutch and the rpms jump up and down a couple times then goes to about 800 rpm. Also when im at idle I push the clutch in and push on the gas the rpms will start to drop like norm then it will jump up to 1500 or 2000 rpms then go back to 800 rpms.

5 Answers

Tiny

ASEMaster6371

March, 24, 2013 AT 5:31 PM

Adding injector cleaner to the tank has little or no effect on injectors. Direct injector cleaning the the only way to clean them correctly.

Check for vacuum leaks. Make sure the passages for the idle air control are clean.

Roy

Tiny

jonp069

March, 24, 2013 AT 5:39 PM

Thanks I have checked all the vacuum lines no leaks I have tryed to find where the iac is there is two different kind of things there and I cant tell whitch one it is.

Tiny

ASEMaster6371

March, 24, 2013 AT 5:41 PM

There is a tps sensor and the other is the iac motor.

Roy

Tiny

jonp069

March, 24, 2013 AT 5:48 PM

Thnaks I appreciate the help

Tiny

ASEMaster6371

March, 24, 2013 AT 5:50 PM

Good luck

Roy

Please login or register to post a reply.

Vacuum Leak Test and Repair - All Cars
Clean Idle Air Control Ford Super Duty 5.4L
Easily Clean Your Throttle Bore Like a Pro
Code Read Retrieval/Clear - Dodge Stratus