Strange vibration from front.

Tiny
COBBSTEVE14
  • 1998 FORD RANGER
  • 168,000 MILES

I have a 98 ranger 4wd 3.0 5sp. When I am driving down the road at random times the truck starts vibrating like I'm running over the hum strip and it rattles kinda like the drive chain fell off in the t-case. If I engage the 4wd and turn it right back off it will go away for a few min. The front end has been re done I put manual hubs on it thinking it was those causing the trouble and the u joints are good. I've got no clue anymore what to check so any help would be awesome.

Do you
have the same problem?
Yes
No
Sunday, October 7th, 2012 AT 4:34 PM

4 Replies

Tiny
ASEMASTER6371
  • EXPERT
  • 25,533 POSTS

Did you remove the front shaft and inspect the joints? Sounds like the issue

Roy

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
Sunday, October 7th, 2012 AT 5:09 PM
Tiny
COBBSTEVE14
  • MEMBER

I checked them they are as tight as can be.

Was this
answer
helpful?
Yes
No
Sunday, October 7th, 2012 AT 5:50 PM
Tiny
ASEMASTER6371
  • EXPERT
  • 25,533 POSTS

Did you remove the shaft and inspect? Tight is not good as they need to move freely.

Roy

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
Sunday, October 7th, 2012 AT 5:55 PM
Tiny
COBBSTEVE14
  • MEMBER

I mean the theres no play in the bearings. It feels like its trying to go into 4wd and only gets half way there. I just dont understand why when I put it in then out of 4wd it goes away and comes back.

Was this
answer
helpful?
Yes
No
Sunday, October 7th, 2012 AT 6:41 PM

Please login or register to post a reply.

Related Engine Vibration Questions

Help us by donating