Dash cluster lights and running tail lights not working. Can you help me troubleshoot the problem

Tiny
PAZZANO
  • MEMBER
  • 1998 DODGE RAM
  • 100,000 MILES
I checked all fuses, and changed the headlight switch. Still not working
Saturday, November 5th, 2011 AT 6:14 PM

7 Replies

Tiny
JACOBANDNICKOLAS
  • MECHANIC
  • 108,779 POSTS
Start with checking the multifunction switch. Power goes through there for the lights too.
Was this
answer
helpful?
Yes
No
Saturday, November 5th, 2011 AT 6:17 PM
Tiny
PAZZANO
  • MEMBER
  • 4 POSTS
Thank You,
This might be a dumb question, but where is that switch located?
Was this
answer
helpful?
Yes
No
Saturday, November 5th, 2011 AT 6:30 PM
Tiny
PAZZANO
  • MEMBER
  • 4 POSTS
Dumb question - I just figured out what the multifunction switch is.
Was this
answer
helpful?
Yes
No
Saturday, November 5th, 2011 AT 6:36 PM
Tiny
JACOBANDNICKOLAS
  • MECHANIC
  • 108,779 POSTS
Not a problem. Let me know if you need wiring schematics or anything else.
Was this
answer
helpful?
Yes
No
Saturday, November 5th, 2011 AT 6:40 PM
Tiny
PAZZANO
  • MEMBER
  • 4 POSTS
I checked the power for the multiswitch and it is good.? I'm lost?
Was this
answer
helpful?
Yes
No
Saturday, November 5th, 2011 AT 6:58 PM
Tiny
PAZZANO
  • MEMBER
  • 4 POSTS
If you can help with any wiring schematics that would be very helpful.
Thanks again for your help.
Was this
answer
helpful?
Yes
No
Saturday, November 5th, 2011 AT 7:40 PM
Tiny
JACOBANDNICKOLAS
  • MECHANIC
  • 108,779 POSTS
I attached 2 schematics for exterior lights. Let me know if they help.
Was this
answer
helpful?
Yes
No
+1
Sunday, November 6th, 2011 AT 5:38 AM

Please login or register to post a reply.

Sponsored links