Car out of contol ! ! !

Tiny
GHOST_RECON_911
  • MEMBER
  • 1997 SATURN SL2
  • 113,000 MILES
My car is trying to get me killed. Ill be sitting at a red light and it will suddenly rev up and try to accelerate. Additionally, as I try to brake, it revs up over and over and it feels sort of like I am hitting bumps. The service engline light randomly comes on, the coolant temp lights (and I say lights because it is a combination of two lights according to my manual) are flashing, and my diagnostic device tells me I have a tft problem. I dont have any idea what to do and I need to fix this problem before I cause a wreck. Please help!~!
Do you
have the same problem?
Yes
No
Friday, September 2nd, 2011 AT 12:13 AM

8 Replies

Tiny
SATURNTECH9
  • EXPERT
It sounds like you have a large vacuum leak and the engine is hittng thr rev limter.I need the exact code numbers you have not the code descriptions.
Was this
answer
helpful?
Yes
No
Friday, September 2nd, 2011 AT 12:34 AM
Tiny
GHOST_RECON_911
  • MEMBER
Something I forgot to mention, on hills (particularly downhill) my car has a tendency to die completely. Sometimes it refuses to start unless I floor the gas pedal.

The error code I recieved on my device -

P0710 trans fluid temp sensor A CKT Range/Performance

thanks for your time and help
Was this
answer
helpful?
Yes
No
Friday, September 2nd, 2011 AT 3:19 PM
Tiny
SATURNTECH9
  • EXPERT
Are you sure its not a P0711 code?From having to floor the gas to start it I would replace the coolant temp sensor its really common for them to go bad on those cars. Also inspect the connector to the sensor if the terminals are green or blue there corroded and you will have to replace the connector also. The sensor are about 10 let me know how it runs afteryou replace the sensor and inspect the connector. If you follow the upper radiator back to the cylinder head of the engine below where the hose goes on you will see the coolant temp sensor screwed into the head. It has a black wire and a yellow wire going to it.
Was this
answer
helpful?
Yes
No
Friday, September 2nd, 2011 AT 3:29 PM
Tiny
GHOST_RECON_911
  • MEMBER
I got the sensor put in and my temp gauge is acting normally now. The car hasnt died on me since. Only three things remain. My car still makes that watery sound, while slowing down the car still****** around, and I hear a rotational clicking sound that increases with my speed. Seems to be coming from my dash. You have already saved my life lol. That car was going crazy. Thanks for your help
Was this
answer
helpful?
Yes
No
Friday, September 9th, 2011 AT 5:29 PM
Tiny
SATURNTECH9
  • EXPERT
With the watery sound could be your a/c drain clogged up and that could be water sloshing around. Have you checked to see if that drain is clogged up?That rotational noise in the dash is probably the odometer gear clicking very common on those cars. Its more of just a noise I havent really seen odometer failure because of it I have replaced a lot of the speedometers for noise under warranty some cars more then once.I was told it was caused by the incorrect or lack of lubricant on gears.I wouldnt worry about it too much. Also what is third issue it looks like for some reason it was edited.
Was this
answer
helpful?
Yes
No
Friday, September 9th, 2011 AT 5:56 PM
Tiny
GHOST_RECON_911
  • MEMBER
Ok I wont worry about the clicking noise then. It edited the word j erk when I said that the car was j erking around when I stop. Whenever I slow down the car revs up and it feels as if the car were trying to stop. And now my heat shielding is randomly falling off the bottom of my car towards the muffler. This is insane!
Was this
answer
helpful?
Yes
No
Sunday, September 11th, 2011 AT 10:23 PM
Tiny
SATURNTECH9
  • EXPERT
The j erking while braking is warped rotors or drums sounds like you live where they salt the roads with the heat shield falling off thats not common at all where they dont salt the roads. So will the idle jump up if your just idling in park when steping on the brake?
Was this
answer
helpful?
Yes
No
Sunday, September 11th, 2011 AT 11:23 PM
Tiny
GHOST_RECON_911
  • MEMBER
No the idle does not jump when I am not in motion. The only reason I dont think it is the rotor being warped is that the engine revs up at the exact same time while coming to a stop? I used hangers to tie up my shielding. I think it will work fine. Its the back shielding anyways. Thank you so much for all of your help.
Was this
answer
helpful?
Yes
No
Wednesday, September 14th, 2011 AT 4:55 PM

Please login or register to post a reply.

Recommended Guides