A/C and radiator fan weird issues

Tiny
ZACH RAMIREZ
  • MEMBER
  • 1997 FORD MUSTANG
  • 4.6L
  • V8
  • 2WD
  • MANUAL
  • 150,000 MILES
Hello, I have the car listed above GT. The A/C used to work fine and one day it just stopped blowing cold. A month after that the radiator fan stopped working.



I have

- Replaced Radiator fan (Still didn't work, wired it to a toggle switch inside)

- Replaced AC Compressor with 2006 GT - (Didn't work)

- Replaced ECT sensor

- Replaced Low and High AC ports (Was losing some pressure out of the high so I replaced both)

- Replaced CCRM. (It was old so I decided to just replace anyways)



I don't have any customs tunes or anything.



When I replaced CCRM I vacuumed the system and put Freon in, the AC clutch kicked ON and OFF allowing freon for a couple seconds then turned off and never came back on. PSI at 45, I can keep on pushing it but it will go into the red. (Happened once and had to flush it again).



CCRM allowed radiator fan to kick on only if AC is on MAX. Fan turns on for about a minute then shuts back off (Had to wire it back to the switch)



As you can see i've tried quite a bit of things. It's very frustrating because I can't seem to find the issue. I live in Texas and it's 105 right now, A/C is my main priority right now lol.



Any help is greatly appreciated!



Thank you!
Do you
have the same problem?
Yes
No
Saturday, July 11th, 2020 AT 1:56 PM

1 Reply

Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi,

I attached the wiring schematic for the system below. Have you checked to make sure the grounds are all good?

Let me know.

Joe
Was this
answer
helpful?
Yes
No
Sunday, July 12th, 2020 AT 8:32 PM

Please login or register to post a reply.

Sponsored links