1997 Rodeo boil-over at idle.

Tiny
KYLE.D.WHEATON
  • 1997 ISUZU RODEO
  • 178,000 MILES

I have a 1997 Isuzu Rodeo, 3.2l, auto, 4x4, a/c non-functional. It has been boiling over at idle for the past several days, but runs fine at driving speeds. Pump fan is good, electric fan cycles on start-up, but, as the a/c doesn't work, that's the only time it runs. Could my pump impeller have quit working? It doesn't look like coolant is circulating.

Do you
have the same problem?
Yes
No
Monday, March 26th, 2012 AT 1:37 AM

5 Replies

Tiny
ASEMASTER6371
  • EXPERT
  • 25,533 POSTS

I would check the thermostat. The radiator may be clogged as well. The last thing I would look at is the water pump.

Roy

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
Monday, March 26th, 2012 AT 1:42 AM
Tiny
KYLE.D.WHEATON
  • MEMBER

If the thermostat is bad, wouldn't that cause overheating while driving as well? (Confused now.)

Was this
answer
helpful?
Yes
No
Monday, March 26th, 2012 AT 2:33 AM
Tiny
ASEMASTER6371
  • EXPERT
  • 25,533 POSTS

It could be not open enough to allow circulation at idle.

Roy

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
Monday, March 26th, 2012 AT 2:35 AM
Tiny
KYLE.D.WHEATON
  • MEMBER

Ah, gotcha! I'll check that out. Thank you very much.

Was this
answer
helpful?
Yes
No
Monday, March 26th, 2012 AT 4:55 AM
Tiny
ASEMASTER6371
  • EXPERT
  • 25,533 POSTS

Good luck

Roy

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
Monday, March 26th, 2012 AT 5:08 AM

Please login or register to post a reply.

Help us by donating