97 SPEEDOMETER NOT WORKING

1997 Ford Escort

Tiny

j.stieg

May, 31, 2012 AT 6:43 PM

I just put in a manuel transmission and the speedometer does not work. I would like to troubleshoot before getting a speed sensor.

Can I get a diagram? Thanks

FOUND 1846 RELATED QUESTIONS

7 Answers

Tiny

rasmataz

May, 31, 2012 AT 7:20 PM

CEL-Are you popping up with a code P0500?

Tiny

j.stieg

May, 31, 2012 AT 8:04 PM

I did get that code(P0500) a few days ago, But that's because I forgot to plug the sensor in after I was done putting in transmission in.

So here is where I'm at I have the sensor plugged in and there are no codes yet after a few miles. Speedometer is still not functioning along with odometer of course.

I am observing that the odometer cluster is mechanical but speed sensor is NOT equipped with a cable. Is this origonal?

Tiny

rasmataz

May, 31, 2012 AT 8:14 PM

Check the instrument cluster

Tiny

j.stieg

May, 31, 2012 AT 9:09 PM

I guess my question is can there be a mechanical cluster that is cableless.
If there is, the cluster would have to be driven by some kind of servo motor?

I would like to see whats origonal, and then replace or repair the problem.

Tiny

rasmataz

May, 31, 2012 AT 10:56 PM

Inspect and test the VSS wire back to the computer and the sensor itself.

Tiny

j.stieg

May, 31, 2012 AT 11:37 PM

Can you give me a diagram of the wiring.

Tiny

rasmataz

May, 31, 2012 AT 11:53 PM

Sorry, I don't have it

Please login or register to post a reply.

Cabin Air Filter Replacement Porsche 911
Cabin Air Filter Replacement
Door Panel Removal & Speaker Replacement
Cabin Air Filter Replacement