I have tried 2 remanufactured alternators there not charging what would cause them to not charge?

Tiny
ASTRO MAN
  • 1997 CHEVROLET ASTRO
  • 219,000 MILES

I have a 1997 chevy astro 4.3liter I replace the alternator twice with remanufactured alternators & it charge sometime I cant figure the problem?

Do you
have the same problem?
Yes
No
Sunday, September 30th, 2012 AT 12:48 AM

5 Replies

Tiny
ASEMASTER6371
  • EXPERT
  • 25,554 POSTS

Make sure the heavy red wire is 12 volts.

The other connector will have a hot wire, key on. Does the light work on the dash?

Roy

Was this
answer
helpful?
Yes
No
Sunday, September 30th, 2012 AT 12:54 AM
Tiny
ASTRO MAN
  • MEMBER

Thanks for the reply asemaster 6371 ! There's only a gauge no light. I tested the heavy red wire with a test light & there's power, I tested the connector wire and it has power with the key on. Tested the battery with dvom & it reads 12.58 with the van off & it read 13.89 w/van running. Sometime when I turn the van off & restart the charging voltage will read 13.01 & start dropping down into low 12's

Was this
answer
helpful?
Yes
No
Sunday, September 30th, 2012 AT 6:31 AM
Tiny
ASEMASTER6371
  • EXPERT
  • 25,554 POSTS

Ok, then it leaves the alternator itself. What kind are you using?

Roy

Was this
answer
helpful?
Yes
No
Sunday, September 30th, 2012 AT 2:55 PM
Tiny
ASTRO MAN
  • MEMBER

If im not mistaking its a delco reman. Im not absolutely sure, I purchased it from a local parts house. I dont know if they do in house rebuilding but it has a warranty. I really would like to try another rebuilder, this is the second alt. From these guys, ill replace it today & see if the problem go away! Thanks again asemaster6371 ill let u know the outcome !

Was this
answer
helpful?
Yes
No
Sunday, September 30th, 2012 AT 4:14 PM
Tiny
ASEMASTER6371
  • EXPERT
  • 25,554 POSTS

Good luck

Roy

Was this
answer
helpful?
Yes
No
Sunday, September 30th, 2012 AT 5:20 PM

Please login or register to post a reply.

Other Alternator Not Charging Questions