Need to replace O2 Sensor (Bank 1 Sensor 2)

Tiny
AARONACURA
  • 1997 ACURA CL
  • 111,111 MILES

Hello,

My car is throwing a P0138 O2 Sensor High Voltage (Bank 1 Sensor 2) CEL error code.

-Is "Sensor 2" the down-stream (post catalytic converter) oxygen sensor?
-Where is "Sensor 2" located?
-Would replacing the down-stream oxygen sensor fix this problem and get rid of the CEL?

I need to pass a emissions test and smog check ASAP. Any advice is greatly appreciated!

Thanks in advance,
Aaron

Do you
have the same problem?
Yes
No
Friday, October 21st, 2011 AT 5:15 PM

5 Replies

Tiny
2CARPROS KEN
  • ADMIN
  • 10,896 POSTS

The bank one sensor 2 is post catalytic converter sensor. Here is a guide and some diagrams (below) that will help you get the job done.

https://www.2carpros.com/articles/how-to-replace-an-oxygen-sensor

and you will need to raise the car safely

https://www.2carpros.com/articles/jack-up-and-lift-your-car-safely

Please let us know if you need anything else to get the problem fixed.

Cheers, Ken

Was this
answer
helpful?
Yes
No
Wednesday, October 11th, 2017 AT 11:35 AM
Tiny
AARONACURA
  • 1997 ACURA CL
  • 111,111 MILES

Hello,

I had my bad OEM oxygen sensor (post CAT) replaced with a Denso oxygen sensor a few months ago. Prior to the new oxygen sensor, I was getting approximately 160-180 miles on half a tank (mix of city/highway driving). Since the new oxygen sensor I'm getting about 100-110 miles on half a tank.

It should be noted that my old O2 sensor was rusted on to the exhaust and the sensor itself was completely rusted through. I can only assume this means it wasn't working properly, if at all.

With the new sensor, the car has A LOT more power and is a lot more responsive, however it's absolutely destroying my gas mileage.

Do I have a bad O2 sensor? What's the deal?

Thanks,
Aaron

Was this
answer
helpful?
Yes
No
Wednesday, October 11th, 2017 AT 11:36 AM (Merged)
Tiny
RASMATAZ
  • MEMBER

View the Oxygen sensor's and coolant temperature sensor live data this will tell you something

Was this
answer
helpful?
Yes
No
Wednesday, October 11th, 2017 AT 11:36 AM (Merged)
Tiny
MIKEJR214
  • 1999 ACURA CL

Electrical problem
1999 Acura CL 4 cyl Two Wheel Drive Automatic 120000 miles

I have a trouble code of p0141 (heated oxygen sensor bank 1 sensor 2) that autozone told me I had when my check engine light came on. I was told this is the one that is right before the cat convert. I bought a replacement from autozone and changed it. The light with the same code still comes on. I have tried to reset the system by taking the battery off but it still comes on. Can you tell me what causes this? Is the sensor still bad? Or what am I doing wrong? I was told there was a sensor fuse, can you tell me where that is and could that be a problem to the check engine light?

Was this
answer
helpful?
Yes
No
Wednesday, October 11th, 2017 AT 11:36 AM (Merged)
Tiny
BLACKOP555
  • EXPERT
  • 10,537 POSTS

Sensor 2 I belive is the one after the catalytic converter on your vehicle, a quick check for this is the first sensor is the one closest to the engine, the second one is the second one, and if you have a 4 straight you may have a 3rd one, which would be furthest from the engine.

Was this
answer
helpful?
Yes
No
Wednesday, October 11th, 2017 AT 11:36 AM (Merged)

Please login or register to post a reply.

Recommended Guides