ENGINE RUNNING ROUGH WHEN CRANKED

  • Tiny
  • Domehome50
  • 1996 PLYMOUTH VOYAGER
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 120,000 MILES

My engine is running rough when cranked. It does not matter if it is hot or cold outside. It does it every time. If I try to push the gas it acts like it is not getting gas. Once the engine gets warm it runs perfect. I think it is a sensor. Any ideas? The engine was replaced 15,000 miles ago. With new plugs and wires.

Do you
have the same problem?
Yes
No
Friday, November 19th, 2010 AT 4:19 AM

2 Replies

  • Tiny
  • Rasmataz
  • MEMBER

Engine running rough or misfiring can be cause by the following:

http://www.2carpros.com/articles/engine-misfires-or-runs-rough

1.Defective spark plug
2.Inadequate spark/coil,defective spark plug wire.
3.Lack of compression
4.False air leakage.
5.Faulty fuel injectors.
6.Insufficient fuel pressure.
7.Contaminated fuel.
8.EGR valve that is leaking.
9.Oxygen sensors.
10.Throttle position sensor.
11.Manifold absolute pressure sensor

Was this
answer
helpful?
Yes
No
Friday, November 19th, 2010 AT 4:20 AM
  • Tiny
  • Domehome50
  • MEMBER

Engine only runs bad when it is first cranked after 5 minutes it runs perfect. It cant be a compression problem. It would not get better after the engine warmed up. I replaced the wires and plugs recently. Would any of these things you suggested make the engine run bad when cold and then run perfect when engine is warm. IT DOES NOT RUN ROUGH THE WHOLE TIME> JUST WHEN ENGINE IS FIRST CRANKED.

Was this
answer
helpful?
Yes
No
Friday, November 19th, 2010 AT 8:11 AM

Please login or register to post a reply.

Other Engine Runs Rough Questions